Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 09:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ЗУП 8.2 -> Внешняя печатная форма. Помогите разобраться?  (Прочитано 4932 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yaposha

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-12-20
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток!
Помогите плиз новичку разобраться.....
Работаю с базой ЗУП 2.5 (2.5.46.1) 1С:Предприятие 8.2 (8.2.14.537)
Для документа ЗаявкаНаОткрытиеСчетов мне нужно сделать внешнюю печатную форму.
Смотрю как работает печать документа; процедуры в модуле формы документа ЗаявкаНаОткрытиеСчетов:

// Процедура - обработчик нажатия на кнопку "Печать по умолчанию"
Процедура ОсновныеДействияФормыПечатьПоУмолчанию(Кнопка)   
// Процедура - обработчик нажатия на кнопку "Печать"
Процедура ОсновныеДействияФормыПечать(Кнопка)

ссылаются на общий модуль УниверсальныеМеханизмы,
где в

Процедура ПечатьПоДополнительнойКнопке(УдалитьДеревоМакетов, Объект, Форма = Неопределено, ТекстКнопки) Экспорт

есть такие строки:

СтруктураВнутреннихПечатныхФорм = Объект.ПолучитьСтруктуруПечатныхФорм()
Объект.Печать(СтрокаКнопки.Имя, 0);

Только не смейтесь плиз! Помогите пожалуйста найти код этих процедур Печать() и ПолучитьСтруктуруПечатныхФорм()?
В модуле объекта ЗаявкаНаОткрытиеСчетов не вижу, в форме тоже нет...(((



Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1

Оффлайн Yaposha

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-12-20
  • Сайт: 
  • Профессия: Программист 1С
Я ее не выгружала, не уверена что это одобрит начальство( Да вроде она стандартная...

Оффлайн Zverff

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 6
  • КПД: 6%
  • Регистрация: 2011-11-22
  • Сайт: 
  • Профессия: Программист 8.1
Те самому внешнею печать делать? или как?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Выделяешь нужную Процедуру/Функцию и жмешь F12
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Yaposha

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-12-20
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за ответы) разобралась что в самом модуле документа нет ф-ии печати, а печать идет из внешней печатной формы, осталось ее доработать....

Оффлайн Yaposha

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-12-20
  • Сайт: 
  • Профессия: Программист 1С
Подскажите плиз как организовать перебор результатов запроса, чтобы вывести список по подразделениям и в них отсортировать по алфавиту фамилии? Что-то я запуталась((((

Функция Печать() Экспорт
   ТабДокумент = Новый ТабличныйДокумент;
   Макет = ПолучитьМакет("Макет");
   ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка"); // Шапка документа.
   ОбластьМакетаСтрокиПодразделение = Макет.ПолучитьОбласть("Подразделение"); // повторяющаяся шапка страницы
   ОбластьМакета = Макет.ПолучитьОбласть("Строка"); // строка работника
   ПодрОфис = Справочники.ПодразделенияОрганизаций.НайтиПоКоду("000000101");
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   РаботникиОрганизацийСрезПоследних.Сотрудник,
                  //|   ВЫБОР
                  //|      КОГДА РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации = &ПодрОфис
                  //|         ТОГДА &ПодрОфис
                  //|      ИНАЧЕ ВЫБОР
                  //|            КОГДА РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации.Родитель = &ПодрОфис
                  //|               ТОГДА &ПодрОфис
                  //|            ИНАЧЕ РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации
                  //|         КОНЕЦ
                  //|   КОНЕЦ КАК ПодразделениеОрганизацииРодитель,
               |    РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации КАК ПодразделениеОрганизацииРодитель,
                  |   РаботникиОрганизацийСрезПоследних.ПервичныйДокумент.Дата КАК ПервичныйДокументДата,
                  |   ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.ФизЛицо,
                  |   ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.КонтрольнаяИнформация,
                  |   ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.НомерЛицевогоСчета,
                  |   ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.Комментарий
                  |ИЗ
                  |   Документ.ЗаявкаНаОткрытиеСчетов.РаботникиОрганизации КАК ЗаявкаНаОткрытиеСчетовРаботникиОрганизации
                  |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Дата, Сотрудник.Физлицо В (&СписокФизЛиц)) КАК РаботникиОрганизацийСрезПоследних
                  |      ПО ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.ФизЛицо = РаботникиОрганизацийСрезПоследних.Сотрудник.Физлицо
                  |ГДЕ
                  |   ЗаявкаНаОткрытиеСчетовРаботникиОрганизации.Ссылка = &Ссылка
                  |
                  |УПОРЯДОЧИТЬ ПО
                  |   ПервичныйДокументДата УБЫВ
                  |ИТОГИ ПО
                  |   ПодразделениеОрганизацииРодитель";
   

   Запрос.УстановитьПараметр("Дата",СсылкаНаОбъект.Дата);
   Запрос.УстановитьПараметр("ПодрОфис",ПодрОфис);
   Запрос.УстановитьПараметр("СписокФизЛиц", СсылкаНаОбъект.РаботникиОрганизации.ВыгрузитьКолонку("ФизЛицо"));
   Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
   
   Результат = Запрос.Выполнить();
*********************************************************************************************
   ВыборкаПодразделений = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   НомСтр = 1;
      
   Пока ВыборкаПодразделений.Следующий() Цикл
      ТабДокумент.Вывести(ОбластьМакетаШапка);
      ОбластьМакетаСтрокиПодразделение.Параметры.Подразделение = "" + ВыборкаПодразделений.ПодразделениеОрганизацииРодитель;
      ТабДокумент.Вывести(ОбластьМакетаСтрокиПодразделение);
      ВыборкаФизЛиц = ВыборкаПодразделений.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      
      ТекФизЛицо = "";
      Пока ВыборкаФизЛиц.Следующий() Цикл
         Если  ТекФизЛицо <> ВыборкаФизЛиц.ФизЛицо Тогда
            ОбластьМакета.Параметры.Ном = НомСтр;
            ОбластьМакета.Параметры.ФИО = ВыборкаФизЛиц.ФизЛицо;
            ОбластьМакета.Параметры.НомКарты = ВыборкаФизЛиц.КонтрольнаяИнформация;
            ОбластьМакета.Параметры.Комент = ВыборкаФизЛиц.Комментарий;
            ТабДокумент.Вывести(ОбластьМакета);
         НомСтр = НомСтр + 1;
         КонецЕсли;
         ТекФизЛицо = ВыборкаФизЛиц.ФизЛицо;
         
      КонецЦикла;
**************************************************************************************
      ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
   КонецЦикла;
   Возврат ТабДокумент;
КонецФункции

Оффлайн Yaposha

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-12-20
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5543
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4356
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1974
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 595
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal