Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите результат запроса перенести на форму  (Прочитано 2138 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
&НаКлиенте
Процедура ФормированиеИмяКорма ()
   проц=аа();
       цк=объект.Владелец;
        стр2=Строка(цк); //назв корма
        т1=0;            //дата последнего посещения
       т2=год(объект.Дата); //текущая, введённая дата
             ид=1;             //нумератор
      як=0;
      сообщить(рроц);
      пока 1<>як цикл
            если    т2=т1     тогда
         ук=т2-2000;
         стр=строка(ук);    //дата с вычетом
         
         ав=стр2+"/"+строка(ид)+"-"+стр; 
         ид="1";
       объект.Наименование=ав;
   як=1;   
   иначе   
      т1=т2;   
   конецесли
КонецЦикла;
КонецПроцедуры
================================

&НаСервере
функция аа()
    Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ ПЕРВЫЕ 1
      |   Номенклатура.Рецепт КАК Рецепт
      |ИЗ
      |   Справочник.Номенклатура КАК Номенклатура
      |
      |УПОРЯДОЧИТЬ ПО
      |   Наименование УБЫВ";

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     рез=ВыборкаДетальныеЗаписи;

Возврат(рез);
    КонецЦикла;
   
Конецфункции


Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
Вообщем проблема такая, мне надо из запроса вытащить его результат. Подскажите может кто знает как это можно осуществить?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
функция аа()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 1
|   Номенклатура.Рецепт КАК Рецепт
|ИЗ
|   Справочник.Номенклатура КАК Номенклатура
|
|УПОРЯДОЧИТЬ ПО
|   Наименование УБЫВ";

Результат = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
рез=ВыборкаДетальныеЗаписи.Рецепт;
Возврат рез;
КонецЦикла;
Конецфункции
Только тот запрос выдаст рецепт первого элемента справочника Номенклатура и все!
Кнопочка Спасибо - слева!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Что-то в последнее время пока поймешь что от тебя хотят... (((
Старею видимо.....

Применительно к вашему коду...
Цикл
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     рез=ВыборкаДетальныеЗаписи;

Возврат(рез);
    КонецЦикла;

вам совсем не нужен. Вместо этого делайте так:

ВыборкаДетальныеЗаписи.Следующий();

Возврат ВыборкаДетальныеЗаписи.Рецепт;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
дада спасибо, я уже сам на работе сделал) всё равно спасибо всем))


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4378
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal