Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не изменяется программно значение реквизита  (Прочитано 3107 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Olga12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Помогите новичку плз
Не работает :dfbsdfbsdf:

Процедура Сформировать()
    Док = СоздатьОбъект("Документ.Лицензия");
Док.ВыбратьДокументы(,);
Пока Док.ПолучитьДокумент()  = 1 Цикл
ДокДог = СоздатьОбъект("Документ.Договор");
ДокДог.ВыбратьПоНомеру(СокрЛП(Док.НомерСублецензионногоДоговора),,);
ДокДог.ПолучитьДокумент();
Док.ДоговорСубЛЦЗ = ДокДог.ТекущийДокумент();
    КонецЦикла
КонецПроцедуры
[/pre]


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Док.Записать(); перед КонецЦикла?
Кнопочка Спасибо - слева!

Оффлайн Olga12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
Док.Записать(); перед КонецЦикла?

Не помогает. В отладчике видно, что
ДокДог.НайтиПоНомеру(СокрЛП(Док.ТекущийДокумент().НомерСублецензионногоДоговора), '10.01.2012') = 0
хотя документ с таким номером есть

Оффлайн Olga12

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
СПЕЦИАЛИСТЫ! Помогите!
Не работает НайтиПоНомеру !
ПОЧЕМУ?

Процедура Сформировать()
    Док = СоздатьОбъект("Документ.Лицензия");
   Док.ВыбратьДокументы();
   ДокДог = СоздатьОбъект("Документ.Договор");
   Пока Док.ПолучитьДокумент()  = 1 Цикл
      ДокДог.НайтиПоНомеру(СокрЛП(Док.ТекущийДокумент().НомерСублецензионногоДоговора));
      Док.ДоговорСубЛЦЗ = ДокДог.ТекущийДокумент(); 
      Док.Записать();
    КонецЦикла      
КонецПроцедуры

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
НайтиПоНомеру(<Номер>,<Дата>,<ИдентВида>)
Дата документа ДокДог точно '10.01.2012' или хотя бы в пределах уникальности номеров или это прошлогодний документ?
У обоих реквизитов (НомерСублецензионногоДоговора и ДокДог.НомерДок) одинаковый тип?
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 277
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal