Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 16:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка в Excel из 1С  (Прочитано 36466 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте уважаемые форумчане!Мне нужно выгружать данные из табличной части документа я пользуясь интернетом написал небольшую процедуру для этого где при нажатии на кнопку должна происходить выгрузка, но вылетают ошибки...

{Документ.Документ1.Форма.ФормаДокумента(14,26)}: Переменная не определена (Значение)
Лист.Cells(1, 1).Value = <<?>>Значение;
{Документ.Документ1.Форма.ФормаДокумента(5,10)}: Процедура или функция с указанным именем не определена (СоздатьОбъект)
Эксель = <<?>>СоздатьОбъект("Excel.Application");


а вот сам текст процедуры

Процедура Кнопка1Нажатие(Элемент)
// Вставить содержимое обработчика.
Попытка
Эксель = СоздатьОбъект("Excel.Application");
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;
Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);
Лист = Книга.Sheets.Add();

Лист.Cells(1, 1).Value = Значение;
Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;
КонецПроцедуры


Если не трудно помогите пожалуйста.Заранее благодарен


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
СоздатьОбъект 
это в семерке, в 8-ке
Новый COMОбъект("Excel.Application")
Где значение переменной Значение? Присвоить же что-то надо сначала переменной

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
СоздатьОбъект 
это в семерке, в 8-ке
Новый COMОбъект("Excel.Application")
Где значение переменной Значение? Присвоить же что-то надо сначала переменной
Спасибо с объектом всё норм щас)
А что ей присвоить можно??просто как бы там же ячейки....

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Ну в ячейку то значение записывать будешь, вот и присвой значение этой переменной.

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Ну в ячейку то значение записывать будешь, вот и присвой значение этой переменной.
Ну вот я присвоил ей 1))он мне и записывает мне эту 1 в эту ячейку.....а мне надо чтоб он всю табличную часть выгружал.....
Как это сделать?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Обходишь циклом строки табличной части и реквизиты записываешь. Ознакомься с документацией)

Оффлайн dimalf

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Программист 1С
Посмотри работу с Эксэль в 8 здесь: file://localhost/E:/Работа%20с%20Excel%20в%201С%208%20_%20Самый%20Классный%20Учебник%201С%20-%20Sky1C.Ru.mht

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!я решил все проблемы, про которые говорил выше, но появились новые.... мне нужно выгрузить в ексель все табличные части  документов которые находятся в форме спискадокумента
 код
&НаКлиенте
Процедура СохранитьВЭксель(Команда)
    ВыгрузитьВЭксель();   
КонецПроцедуры


&НаСервере
Процедура ВыгрузитьВЭксель()     
ВыборкаДокументов= Документы.Задание.Выбрать();   
Пока ВыборкаДокументов.Следующий() цикл 
Попытка
Эксель = Новый COMОбъект("Excel.Application")
Исключение
Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена на данном компьютере!");
Возврат;
КонецПопытки;



Книга = Эксель.WorkBooks.Add();
Лист = Книга.WorkSheets(1);

НомерСтроки=НомерСтроки+1;

Лист.Cells(НомерСтроки, 1).Value = Строка(Строка.Студент);
Лист.Cells(НомерСтроки, 2).Value = Строка(Строка.ПН);
Лист.Cells(НомерСтроки, 3).Value = Строка(Строка.ВТ);
Лист.Cells(НомерСтроки, 4).Value = Строка(Строка.СР);
Лист.Cells(НомерСтроки, 5).Value = Строка(Строка.ЧТ);
Лист.Cells(НомерСтроки, 6).Value = Строка(Строка.ПТ);
Лист.Cells(НомерСтроки, 7).Value = Строка(Строка.СБ);
Лист.Cells(НомерСтроки, 8).Value = Строка(Строка.ВС);


КонецЦикла;   
КонецЦикла;   
Попытка
Книга.SaveAs("C:\Users\Администратор\Downloads\1с");
Исключение
Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
Возврат;
КонецПопытки;
Эксель.Application.Quit();

КонецПроцедуры

но мне нужно чтобы каждый документ выгружался на отдельный лист книги екселя.. как это сделать??Заранее спасибо.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Сам не пробовал, но как-то так
Лист = Книга.Sheets.Add();

Оффлайн v_kuzmin

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 2
  • КПД: 2%
  • Регистрация: 2011-11-09
  • Сайт: 
  • Профессия: Ученик 1С
Сам не пробовал, но как-то так
Лист = Книга.Sheets.Add();
т.е нужно сделать будет цикл по листам?чтобы они добавлялись пока не закончатся доки?


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4266
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2535
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8745
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 995
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1292
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
22 Сообщений
alexandr_ll
17 Сообщений
andron81_81
17 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal