Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 04:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Неправильная обработка запроса в 1с 8.2  (Прочитано 18553 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте помогите с такой проблемой. Есть в 1с-ке отчёт по складам, который формируется на основе регистра. Отчёт показывает правильное состояние складов, но когда я пытаюсь получить остатки регистра через запрос по определённым параметрам в документе и вывести в табличную часть конкретные значения, то выводятся не совсем корректные сведения: часть выводится правильно, а по некоторым позициям вылазят непонятные минуса. Текст запроса проверял, ошибок нет (с другими регистрами примерно такие-же запросы проходят правильно), пробовал разные виды запросов (по остаткам, суммы, обороты) - не помогает. И иногда как будто некоторые документы отменяются( то есть документ числится проведённым, но запросы к регистру не хотят видеть движение, хотя запись в регистре есть. Отмена проведения документа и проведение его заново проблему решают, но документов туева хуча и искать какой именно документ отменился порой очень сложно). Если кто сталкивался с подобным подскажите есть ли решение без необходимости создавать регистр заново?


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Скорее всего не правильно создаете запрос... по идее если отчет по одному и тому же регистру - данные должны быть одинаковыми
Тазовод)

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
в том-то и проблема, что большинство позиций при запросе совпадает с отчётом, а часть вылазит минусами (сразу говорю проблема не в периоде -пробовал выставлять на завтрашнее число не помогает), причём минуса вылазят не в течении дня а где попало

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Какая база? отчет делаете на компановке? текст запроса можно увидеть?
Тазовод)

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
Движения.РегистрЗаказов.Записывать = Истина;
Для Каждого ТекСтрокаТовар Из Товар Цикл
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РегистрЗаказовОстатки.Магазин,
| РегистрЗаказовОстатки.Покупатель,
| РегистрЗаказовОстатки.Номенклатура,
| РегистрЗаказовОстатки.Дата,
| СУММА(РегистрЗаказовОстатки.ЗаказаноОстаток) КАК ЗаказаноОстаток,
| СУММА(РегистрЗаказовОстатки.НаСкладеОстаток) КАК НаСкладеОстаток
|ИЗ
| РегистрНакопления.РегистрЗаказов.Остатки КАК РегистрЗаказовОстатки
|ГДЕ
| РегистрЗаказовОстатки.Номенклатура = &Номенклатура
|
|СГРУППИРОВАТЬ ПО
| РегистрЗаказовОстатки.Магазин,
| РегистрЗаказовОстатки.Покупатель,
| РегистрЗаказовОстатки.Номенклатура,
| РегистрЗаказовОстатки.Дата";

Запрос.УстановитьПараметр("Номенклатура", ТекСтрокаТовар.Номенклатура);
Запрос.УстановитьПараметр("Дата", ТекстрокаТовар.ДатаЗаказа);
Запрос.УстановитьПараметр("Магазин", ТекСтрокаТовар.Магазин);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// регистр РегистрЗаказов Расход
Сообщить(НаскладеОстаток);
Сообщить(ЗаказаноОстаток);
Если ВыборкаДетальныеЗаписи.НаСкладеОстаток>0 тогда
Сообщить( "Перемещение на склад "+ТекстрокаТовар.Магазин+" номенклатуры"+ТекСтрокаТовар.Номенклатура);
Движение = Движения.РегистрЗаказов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Магазин = ТекСтрокаТовар.Магазин;
Движение.Номенклатура = ТекСтрокаТовар.Номенклатура;
Движение.Дата = ТекСтрокаТовар.ДатаЗаказа;
Движение.НаСкладе = ТекСтрокаТовар.Количество;

Движения.ТоварыНаСкладах.Записывать = Истина;
Движение = Движения.ТоварыНаСкладах.Добавить();
Движение.Период = Дата;
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Номенклатура = ТекстрокаТовар.Номенклатура;
Движение.Склад = Справочники.Склады.НайтиПоНаименованию(ВыборкаДетальныеЗаписи.Магазин);
Движение.Количество = ТеКстрокаТовар.Количество;
Иначе
Сообщить("Удаление номенклатуры "+ТекСтрокаТовар.Номенклатура+" из заказа");
Движение = Движения.РегистрЗаказов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Магазин = ТекСтрокаТовар.Магазин;
Движение.Номенклатура = ТекСтрокаТовар.Номенклатура;
Движение.Дата = ТекСтрокаТовар.ДатаЗаказа;
Движение.Заказано = ТекСтрокаТовар.Количество;

КонецЕсли;
// Вставить обработку выборки ВыборкаДетальныеЗаписи
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
КонецЦикла

вот например такой запрос, отчёт на компановке конструктором, некоторые позиции видит минусами, некоторые вообще нулевыми, хотя по отчёту стоят плюсом.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
база какая? чтобы наглядно посмотреть и какой отчет,
Тазовод)

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
1с 8.2, конфигурацию писал сам практически с нуля, проблема возникла буквально недавно и только в одном регистре (до этого все запросы шли правильно, платформа не обновлялась, в корневые обработки изменения не вносились), отчёт делал конструктором, вручную не дописывал, так что проблема врятли в нём, к тому же не поленился залезть в регистр и документы и пересчитать сумму на калькуляторе для проблемных позиций, и получается что отчёт прав. в стандартных конфигурациях таких документов и отчётов нет, так что повторить это можно увы только в этой конфигурации (((

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Так плохо думать, не видя глазами((  то есть, в регистре данные правильные, станд. отчет работает правильно, а Ваш нет? так? увидеть бы конфигурацию в глаза...
Тазовод)

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
ну примерно так, кстати сейчас начал ковырялся ещё, и нашёл такую закономерность, что старые обработки которые  писались примерно месяца полтора назад с запросами к этому регистру работают правильно, а новые неправильно, вообще какой-то маразм (((

Оффлайн Baltazarar

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-06
  • Сайт: 
  • Профессия: Программист 8.1
у меня уже случался подобный глюк при создании отчёта, только там проблема была с форматированием - ни с того ни с сего отчёт начал выводиться не в том формате, в котором должен был быть, но там проще: удалил отчёт, создал новый с точно такими же параметрами, и заработало как надо, но тут перезабивать регистр не вариант


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12284
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8580
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Обработка "ПодборНоменклатуры"

Автор BigAnnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2972
Последний ответ 18 Апр 2012, 20:38
от Dethmontt
Обработка "СогласованиеЗаявок"

Автор Денис АндрушкоРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 809
Последний ответ 24 Сен 2016, 00:37
от Денис Андрушко
Обработка "Ввести реализацию"

Автор inoifantomРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1724
Последний ответ 27 Мар 2011, 12:57
от inoifantom

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 186
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal