Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 22:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите с реализацией  (Прочитано 2704 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Я начала создавать отчет в котором будут выводиться только документы реализация и поступление тмц..помогите с кодом пожалуйста

вот на чем остановилась:
//*******************************************
Процедура Сформировать()         
   Таб=СоздатьОбъект("Таблица");
   Док=СоздатьОбъект("Документ");
   Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Пока Док.ПолучитьДокумент()=1 Цикл
      Если Док.Проведеня()=1 Тогда
            Таб.ВывестиСекцию("Строка");
      КонецЕсли;   
   КонецЦикла;   
   
   Таб.ТОлькоПросмотр(1);
   Таб.Показать();

КонецПроцедуры

Процедура ПриОткрытии()
   ДатаНачала=Дата(ТекущаяДата()+1);
   ДатаКонца=ДатаНачала;
КонецПроцедуры   


Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
в таблице которую создаю будет две колонки(документы и коментарий) коментарии берутся из данных документов...если они пустые то не выводить их..

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
забыла указать 1С Предприятие 7.7 конфигурация Торговля и Склад

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Так попробуй

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ДатаНачала по ДатаКонца;
|Обрабатывать НеПомеченныеНаУдаление;
|ТекущийДокумент = Документ.ПоступлениеТМЦ.ТекущийДокумент, Документ.Реализация.ТекущийДокумент;
|Группировка ТекущийДокумент;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей ТекущийДокумент
Таб.ВывестиСекцию("ТекущийДокумент");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Процедура ПриОткрытии()
   ДатаНачала=Дата(ТекущаяДата()+1);
   ДатаКонца=ДатаНачала;
КонецПроцедуры   
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Так попробуй

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ДатаНачала по ДатаКонца;
|Обрабатывать НеПомеченныеНаУдаление;
|ТекущийДокумент = Документ.ПоступлениеТМЦ.ТекущийДокумент, Документ.Реализация.ТекущийДокумент;
|Группировка ТекущийДокумент;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей ТекущийДокумент
Таб.ВывестиСекцию("ТекущийДокумент");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Процедура ПриОткрытии()
   ДатаНачала=Дата(ТекущаяДата()+1);
   ДатаКонца=ДатаНачала;
КонецПроцедуры   

Спасибо большое Сейгей :*
Я кстати вот как сделала:
//*******************************************
Процедура Сформировать()         
   Таб=СоздатьОбъект("Таблица");
   Док=СоздатьОбъект("Документ");   
   Таб.ВывестиСекцию("Шапка");
   Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Пока Док.ПолучитьДокумент()=1 Цикл
      Если (Док.Вид()="ПоступлениеТМЦ") Или (Док.Вид()="Реализация") Тогда
         Если ПустоеЗначение(Док.Комментарий)=0 Тогда
            Если Док.Проведен()=1 Тогда
               Таб.ВывестиСекцию("Строка");
            КонецЕсли;   
         КонецЕСли;
      КонецЕСли;   
   КонецЦикла;   
   
   Таб.ТОлькоПросмотр(1);
   Таб.Показать();

КонецПроцедуры

Процедура ПриОткрытии()
   ДатаНачала=Дата(ТекущаяДата()+1);
   ДатаКонца=ДатаНачала;
КонецПроцедуры   


но хочу еще колонки добавить с суммай и датой..вот думаю пока как это в коде прописать...

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Дата = Док.ДатаДок; Сумма = Док.Итог("Сумма")
Если выбирать запросом, то отчет строится быстрее
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Дата = Док.ДатаДок; Сумма = Док.Итог("Сумма")
Если выбирать запросом, то отчет строится быстрее
Спасибо большое Сергей:* Всегда ты выручаешь)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
109 Сообщений
AIFrame
105 Сообщений
alex0402
30 Сообщений
alexandr_ll
19 Сообщений
kiksi
19 Сообщений
pavl_vs
19 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
BuhRust
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 362
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal