Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 19:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите связать 2 ТЧ  (Прочитано 1666 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VladimirVladimir

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-11
  • Сайт: 
  • Профессия: Ученик 1С
добрый день, мне нужно связать 2 табличные части в Расходной накладной так, чтобы при выборе номенклатуры из первой ТЧ - во второй ТЧ показывались партии, по которым можно списать эту номенклатуру

 пишу в форме документа (ТЧ1-СписокНоменклатуры, ТЧ2-СписокПартий):

 &НаСервере
 Процедура СписокНоменклатурыПриАктивизацииСтроки(Элемент)

 Элементы.СписокПартий.ОтборСтрок.Номенклатура.Использование = Истина;
 Элементы.СписокПартий.ОтборСтрок.Номенклатура.Значение = Элементы.СписокНоменклатуры.ТекущаяСтрока.Номенклатура;
 Элементы.СписокПартий.ОтборСтрок.Номенклатура.ВидСравнения = ВидСравнения.Равно;

 КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А в чем вопрос?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн VladimirVladimir

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-11
  • Сайт: 
  • Профессия: Ученик 1С
не работает

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Что именно то не работает.
Табличные части это динамические списки?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн VladimirVladimir

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-11
  • Сайт: 
  • Профессия: Ученик 1С
всё, спасибо, решено

&НаКлиенте
Процедура СписокНоменклатурыПриАктивизацииСтроки(Элемент)
   Если Элементы.СписокНоменклатуры.ТекущаяСтрока <> Неопределено Тогда 
      СТЧ=Элементы.СписокНоменклатуры.ТекущиеДанные;
      Элементы.Списокпартий.ОтборСтрок = Новый ФиксированнаяСтруктура("Номенклатура", СТЧ.Номенклатура);//Элемент.ТекущиеДанные.Номенклатура);
   КонецЕсли;
КонецПроцедуры


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4303
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5560
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5901
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4387
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1986
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal