Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 12:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вставка изображения в форму элемента  (Прочитано 5145 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LavrS

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте.
Вот код вставки изображения в форму элемента:

Процедура ОсновноеИзображениеНажатие(Элемент)
     
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл с фотографией";
Диалог.ПолноеИмяФайла = "";
Диалог.ПредварительныйПросмотр = Истина;
Диалог.Фильтр =
"Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
+ "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
+ "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
+ "Формат TIFF (*.tif)|*.tif|"
+ "Формат GIF (*.gif)|*.gif|"
+ "Формат PNG (*.png)|*.png|"
+ "Формат icon (*.ico)|*.ico|"
+ "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|"; // картинки
 

Если Диалог.Выбрать() Тогда
    ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
    ЭлементыФормы.ОсновноеИзображение.Картинка = ВыбранноеФото;
Иначе
    Отказ = Истина;
    Возврат;
КонецЕсли;

Хранилище = Новый ХранилищеЗначения(ЭлементыФормы.ОсновноеИзображение.Картинка.ПолучитьДвоичныеДанные());

// сохранение значения типа ХранилищеЗначения в базе данных
 
НовНоменклатура = Справочники.Модель.СоздатьЭлемент();
НовНоменклатура.Наименование = "Менеджер";
// реквизит Изображение имеет тип ХранилищеЗначения
 
НовНоменклатура.Изображение = Хранилище;
НовНоменклатура.Записать();
КонецПроцедуры
Процедура ПоказатьКартинку (НовНоменклатура)
      Если ТипЗнч(НовНоменклатура.Изображение) = Тип("ХранилищеЗначения") Тогда
            ЭлементыФормы.ОсновноеИзображение.Картинка = Новый Картинка (НовНоменклатура.Изображение.Получить());
      КонецЕсли;
  КонецПроцедуры
 

Картинка отображается но после записи не сохраняется, может кто подскажет что делать?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вставить вот это в процедуру при открытии
Процедура ПоказатьКартинку (НовНоменклатура)
      Если ТипЗнч(НовНоменклатура.Изображение) = Тип("ХранилищеЗначения") Тогда
            ЭлементыФормы.ОсновноеИзображение.Картинка = Новый Картинка (НовНоменклатура.Изображение.Получить());
      КонецЕсли;
  КонецПроцедуры
 
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн LavrS

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Программист 8.1
Не работает, может изображение вообще не сохраняется в хранилище?


Теги:
 

Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2065
Последний ответ 18 Янв 2017, 12:32
от sertak
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 813
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3697
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4146
Последний ответ 13 Июн 2017, 12:17
от Whisper
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 690
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
alexandr_ll
34 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений

* Кто онлайн

  • Точка Гостей: 738
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal