Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с кодом для колонки долга в ФормеСписка заказа покупателя  (Прочитано 1814 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zzzzzip

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте! Помогите с кодом для дополнительной колонки с долгом в форме списка Заказов покупателей в УТ 10.3. Заранее Спасибо.

Я только учусь, так что мой код содержит много ошибок сильно не ругайте.


Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

Если Элемент.Колонки.СуммаДолга.Видимость Тогда
  Запрос = Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСКонтрагентамиОстатки.СуммаВзаиморасчетовОстаток КАК СуммаДолга,
| ВзаиморасчетыСКонтрагентамиОстатки.Контрагент КАК Контрагент
|ИЗ
| РегистрНакопления.ВзаиморасчетыСКонтрагентами.Остатки КАК ВзаиморасчетыСКонтрагентамиОстатки
|ГДЕ
| И ВзаиморасчетыСКонтрагентамиОстатки.Контрагент В(&МассивОбъектов)");

Запрос.УстановитьПараметр("СуммаВзаиморасчетовОстаток", СуммаДолга); // тут ошибка переменой СуммаДолга
МассивОбъектов = Новый Массив;
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
   МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
  КонецЦикла;
  Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
  ТабОбъектов = Запрос.Выполнить().Выгрузить();
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
 
   Нашли = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "СуммаДолга");
   ОформлениеСтроки.Ячейки.СуммаДолга.Значение = ?(Нашли <> Неопределено, Нашли.Контрагент, "");
  КонецЦикла;
КонецЕсли;


КонецПроцедуры
Колонке присвоено имя СуммаДолга, создан реквизит СуммаДолга в реквизитах документа. 


Оффлайн zzzzzip

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-25
  • Сайт: 
  • Профессия: Бухгалтер
Сделал сам.
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

Если Элемент.Колонки.СуммаДолга.Видимость Тогда
  Запрос = Новый Запрос("ВЫБРАТЬ
|ВзаиморасчетыСКонтрагентамиОстатки.СуммаВзаиморасчетовОстаток КАК СуммаДолга,
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Ссылка КАК Контрагент,
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Представление
|ИЗ
|РегистрНакопления.ВзаиморасчетыСКонтрагентами.Остатки КАК ВзаиморасчетыСКонтрагентамиОстатки
|ГДЕ
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Ссылка В (&МассивОбъектов)
|");



МассивОбъектов = Новый Массив;
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
   МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка.Контрагент);
  КонецЦикла;
  Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
  ТабОбъектов = Запрос.Выполнить().Выгрузить();
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
 
   Нашли = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка.Контрагент, "Контрагент");
   ОформлениеСтроки.Ячейки .СуммаДолга.Значение = ?(Нашли <> Неопределено, Нашли.СуммаДолга, "")
   
КонецЦикла;
КонецЕсли;
КонецПроцедуры


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4378
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 136
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal