Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 сен 2021, 00:13

Помогите с кодом для колонки долга в ФормеСписка заказа покупателя

Автор zzzzzip, 25 фев 2012, 17:55

0 Пользователей и 1 гость просматривают эту тему.

zzzzzip

Здравствуйте! Помогите с кодом для дополнительной колонки с долгом в форме списка Заказов покупателей в УТ 10.3. Заранее Спасибо.

Я только учусь, так что мой код содержит много ошибок сильно не ругайте.


Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

Если Элемент.Колонки.СуммаДолга.Видимость Тогда
  Запрос = Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСКонтрагентамиОстатки.СуммаВзаиморасчетовОстаток КАК СуммаДолга,
| ВзаиморасчетыСКонтрагентамиОстатки.Контрагент КАК Контрагент
|ИЗ
| РегистрНакопления.ВзаиморасчетыСКонтрагентами.Остатки КАК ВзаиморасчетыСКонтрагентамиОстатки
|ГДЕ
| И ВзаиморасчетыСКонтрагентамиОстатки.Контрагент В(&МассивОбъектов)");

Запрос.УстановитьПараметр("СуммаВзаиморасчетовОстаток", СуммаДолга); // тут ошибка переменой СуммаДолга
МассивОбъектов = Новый Массив;
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
   МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
  КонецЦикла;
  Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
  ТабОбъектов = Запрос.Выполнить().Выгрузить();
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
 
   Нашли = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "СуммаДолга");
   ОформлениеСтроки.Ячейки.СуммаДолга.Значение = ?(Нашли <> Неопределено, Нашли.Контрагент, "");
  КонецЦикла;
КонецЕсли;


КонецПроцедуры

Колонке присвоено имя СуммаДолга, создан реквизит СуммаДолга в реквизитах документа. 

zzzzzip

Сделал сам.
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

Если Элемент.Колонки.СуммаДолга.Видимость Тогда
  Запрос = Новый Запрос("ВЫБРАТЬ
|ВзаиморасчетыСКонтрагентамиОстатки.СуммаВзаиморасчетовОстаток КАК СуммаДолга,
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Ссылка КАК Контрагент,
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Представление
|ИЗ
|РегистрНакопления.ВзаиморасчетыСКонтрагентами.Остатки КАК ВзаиморасчетыСКонтрагентамиОстатки
|ГДЕ
|ВзаиморасчетыСКонтрагентамиОстатки.Контрагент.Ссылка В (&МассивОбъектов)
|");



МассивОбъектов = Новый Массив;
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
   МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка.Контрагент);
  КонецЦикла;
  Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
  ТабОбъектов = Запрос.Выполнить().Выгрузить();
  Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
 
   Нашли = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка.Контрагент, "Контрагент");
   ОформлениеСтроки.Ячейки .СуммаДолга.Значение = ?(Нашли <> Неопределено, Нашли.СуммаДолга, "")
   
КонецЦикла;
КонецЕсли;
КонецПроцедуры

Теги:

Похожие темы (5)

7676

Ответов: 5
Просмотров: 2256

62740

Ответов: 3
Просмотров: 1522

16661

Ответов: 2
Просмотров: 2160

Рейтинг@Mail.ru Rambler's Top100

Поиск