Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 11:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как убрать пометку с xml-файлов, загружаемых в 1С 7.7?  (Прочитано 2318 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lilitana

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! Поздравляю всех с Днем защитника отечества, желаю всего самого лучшего!
Подскажите, пожалуйста, как убрать пометку с xml-файлов, загружаемых в 1С 7.7, которые не были загружены в предыдущем цикле загрузки?
Есть обработка, которая загружает xml-файлы. В ней есть процедура, которая формирует список xml-файлов. В этом списке с любого файла можно снять пометку, соответственно    загрузятся только те файлы, на которых есть пометка. «Хорошие» файлы загружаются, создают документы и автоматически удаляются. Если в одном из загружаемых файлов есть ошибка, то такой файл не загрузится, выведется сообщение об ошибке и загрузка остановится. Повторное нажатие кнопки «Загрузить» повторяет загрузку оставшихся файлов либо до следующего файла с ошибкой, либо до конца списка файлов.
Нужно, чтобы со всех незагрузившихся  в предыдущем цикле файлов снималась пометка в списке файлов, тогда бы шла загрузка только файлов без ошибок. Я пока что сделала только так, чтобы в текущем цикле если файл содержит ошибку, то с него снимается эта пометка. Но после того, как найдется второй ошибочный файл, то пометка снимается со второго файла, а на первом восстанавливается.  Подскажите, пожалуйста, как убрать пометку и с текущего файла, и со всех предыдущих ошибочных файлов?
Процедура СформСписФайлов()
    Тзс=СоздатьОбъект("ТаблицаЗначений");
    Тзс.НоваяКолонка("Наим");
    Тзс.НоваяКолонка("Дат");
    Тзс.НоваяКолонка("Ном");
    СпФайлов.УдалитьВсе();
    МаскаИмени="C:\Tunes\obmen8_7\02-ПУ-*.xml";
    Зн=ФС.НайтиПервыйФайл(МаскаИмени);
    Пока ПустаяСтрока(Зн)=0 Цикл
        Тзс.НоваяСтрока();
        Тзс.Наим=Зн;
        Тзс.Ном=Лев(Зн,12);
        Чис=Сред(Зн,14,2);
        Мес=Сред(Зн,17,2);
        Год=Сред(Зн,20,4);
    Тзс.Дат=Дата(Год,Мес,Чис);
        Зн=ФС.НайтиСледующийФайл();
    КонецЦикла;
    Тзс.Сортировать("Дат,Ном");
    Тзс.ВыбратьСтроки();
    I=1;
    Пока Тзс.ПолучитьСтроку()=1 Цикл
        СпФайлов.ДобавитьЗначение(Тзс.Наим);
        СпФайлов.Пометка(I,1);
        I=I+1;
    КонецЦикла;   
КонецПроцедуры


Процедура Загрузить()
------------------------------
    Для к=1 По СпФайлов.РазмерСписка() Цикл
Если СпФайлов.Пометка(к)=0 Тогда
            Продолжить;
        КонецЕсли;
    Если ТипОперации= "ВыгрузкаАктовВыполненныхУслугПоНаселению" Тогда 
         ------------------------------------------------------
    ОшибкаЗагрузки=0;
        СоздатьДокументы();
            Если ОшибкаЗагрузки<>0 Тогда 
                Предупреждение("Загрузка прекращена, ошибка в файле "+ИмяФайла);
            СформСписФайлов();
                СпФайлов.Пометка(к,0);    
            Возврат;
            Иначе ФС.УдалитьФайл(ИмяФайла);
            КонецЕсли;
        Иначе
            Предупреждение("В файле неверно задана Операция. Загрузка прекращается");
            Возврат;
        КонецЕсли;
    КонецЦикла;   
    СформСписФайлов();
КонецПроцедуры


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
если закомментировать СформСписФайлов(); (оба раза)- что нибудь изменится?
Кнопочка Спасибо - слева!

Оффлайн Lilitana

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 1С
да, повторно загрузить нельзя будет


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 860
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal