Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 23:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите изменить данные  (Прочитано 7367 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonxsl

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте друзья! Искал, искал я в сети решение вопроса, да те что нашел не помогают.
Нужно мне изменить Грузоотправителя с "он же" на сокращенное название+юридический адрес.
Как я не пробовал, ничего не выходит. И переменные ставил и вручную адрес набирал - результат нулевой.
Помогите, что и где нужно поменять?

Функция ПечатьСчетаФактуры(ДанныеДляПечати) Экспорт

ТабДокумент = Новый ТабличныйДокумент;

Если Дата < '20090609' Тогда
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура283";
Макет = ПолучитьОбщийМакет("СчетФактура283");
Иначе
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура451";
Макет = ПолучитьОбщийМакет("СчетФактура451");
КонецЕсли;

СведенияОбПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
СведенияОПоставщике  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Поставщик, Дата);
СведенияОГрузоотправителе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(?(ДанныеДляПечати.Грузоотправитель = "он же", Неопределено, ДанныеДляПечати.Грузоотправитель), Дата);
СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Грузополучатель, Дата);
// Выводим шапку
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати);
ЗаголовокДляПечати = ОбщегоНазначения.СформироватьЗаголовокДокумента(ДанныеДляПечати, "Счет-фактура");
ОбластьМакета.Параметры.Номер = ЗаголовокДляПечати;

Если ДанныеДляПечати.Свойство("АдресДоставки")
И НЕ ПустаяСтрока(ДанныеДляПечати.АдресДоставки) Тогда
ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "
+ ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель),
ДанныеДляПечати.АдресДоставки,
ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "НаименованиеДляПечатныхФорм") + ", " + ДанныеДляПечати.АдресДоставки);
Иначе
ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "
+ ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель),
"",
ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "НаименованиеДляПечатныхФорм, ФактическийАдрес,"));
КонецЕсли;

Если Дата < '20090609'
ИЛИ ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НалоговыйАгент Тогда
ОбластьМакета.Параметры.ПредставлениеПоставщика = "Продавец: "
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "НаименованиеДляПечатныхФорм,");
Иначе
ОбластьМакета.Параметры.ПредставлениеПоставщика = "Продавец: "
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,");
СокращенноеНаименование = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "СокращенноеНаименование,", Ложь);
Если НЕ ПустаяСтрока(СокращенноеНаименование) Тогда
ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбластьМакета.Параметры.ПредставлениеПоставщика + " (" + СокращенноеНаименование + ")";
КонецЕсли;
КонецЕсли;

ОбластьМакета.Параметры.АдресПоставщика = "Адрес: " + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ЮридическийАдрес,");

Если НЕ (ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НалоговыйАгент
И ДоговорКонтрагента.ВидАгентскогоДоговора = Перечисления.ВидыАгентскихДоговоров.Нерезидент) Тогда

КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "КПП,", Ложь);
Если ЗначениеЗаполнено(КПП) Тогда
КПП = "/" + КПП;
КонецЕсли;
ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: "
+ ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ИНН,", Ложь) + КПП;

Иначе
ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: "
КонецЕсли;

ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: "+
+ ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузоотправитель),
"",
?(ДанныеДляПечати.Грузоотправитель = "он же",
ДанныеДляПечати.Грузоотправитель,
ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузоотправителе,  "НаименованиеДляПечатныхФорм,ФактическийАдрес,")));


Оффлайн Dimonxsl

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Ученик 1С
Извините, что то с форматированием.

Цитировать
Функция ПечатьСчетаФактуры(ДанныеДляПечати) Экспорт
   
   ТабДокумент = Новый ТабличныйДокумент;

   Если Дата < '20090609' Тогда
      ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура283";
      Макет = ПолучитьОбщийМакет("СчетФактура283");
   Иначе
      ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СчетФактураВыданный_СчетФактура451";
      Макет = ПолучитьОбщийМакет("СчетФактура451");
   КонецЕсли;
   
   СведенияОбПокупателе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Покупатель, Дата);
   СведенияОПоставщике  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Поставщик, Дата);
   СведенияОГрузоотправителе = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(?(ДанныеДляПечати.Грузоотправитель = "он же", Неопределено, ДанныеДляПечати.Грузоотправитель), Дата);
   СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(ДанныеДляПечати.Грузополучатель, Дата);
   // Выводим шапку
   ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   ОбластьМакета.Параметры.Заполнить(ДанныеДляПечати);
   ЗаголовокДляПечати = ОбщегоНазначения.СформироватьЗаголовокДокумента(ДанныеДляПечати, "Счет-фактура");
   ОбластьМакета.Параметры.Номер = ЗаголовокДляПечати;
   
   Если ДанныеДляПечати.Свойство("АдресДоставки")
      И НЕ ПустаяСтрока(ДанныеДляПечати.АдресДоставки) Тогда
      ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "
         + ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель),
         ДанныеДляПечати.АдресДоставки,
         ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "НаименованиеДляПечатныхФорм") + ", " + ДанныеДляПечати.АдресДоставки);
   Иначе
      ПредставлениеГрузополучателя = "Грузополучатель и его адрес: "
         + ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузополучатель),
         "",
         ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе, "НаименованиеДляПечатныхФорм, ФактическийАдрес,"));
   КонецЕсли;

   Если Дата < '20090609'
      ИЛИ ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НалоговыйАгент Тогда
      ОбластьМакета.Параметры.ПредставлениеПоставщика = "Продавец: "
         + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "НаименованиеДляПечатныхФорм,");
   Иначе
      ОбластьМакета.Параметры.ПредставлениеПоставщика = "Продавец: "
         + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ПолноеНаименование,");
      СокращенноеНаименование = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "СокращенноеНаименование,", Ложь);
      Если НЕ ПустаяСтрока(СокращенноеНаименование) Тогда
         ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбластьМакета.Параметры.ПредставлениеПоставщика + " (" + СокращенноеНаименование + ")";
      КонецЕсли;
   КонецЕсли;
   
   ОбластьМакета.Параметры.АдресПоставщика = "Адрес: " + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ЮридическийАдрес,");
   
   Если НЕ (ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НалоговыйАгент
      И ДоговорКонтрагента.ВидАгентскогоДоговора = Перечисления.ВидыАгентскихДоговоров.Нерезидент) Тогда
      
      КПП = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "КПП,", Ложь);
      Если ЗначениеЗаполнено(КПП) Тогда
         КПП = "/" + КПП;
      КонецЕсли;
      ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: "
         + ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике, "ИНН,", Ложь) + КПП;
         
   Иначе
      ОбластьМакета.Параметры.ИННпоставщика = "ИНН/КПП продавца: "
   КонецЕсли;
      
   ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: "+
      + ?(НЕ ЗначениеЗаполнено(ДанныеДляПечати.Грузоотправитель),
      "",
      ?(ДанныеДляПечати.Грузоотправитель = "он же",
         ДанныеДляПечати.Грузоотправитель,
         ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузоотправителе,  "НаименованиеДляПечатныхФорм,ФактическийАдрес,")));

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Нужно смотреть где заполняются "ДанныеДляПечати"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AntonB

  • Модератор
  • *****
  • Сообщений: 402
  • РЕПУТАЦИЯ: 74
  • КПД: 18%
  • Регистрация: 2011-05-26
  • Сайт: 
  • Профессия: Программист 8.1
Делал на другой конфигурации. Попробуйте вот так (заменить абзац в самом конце Вашего фрагмента):
ОбластьМакета.Параметры.ПредставлениеГрузоотправителя = "Грузоотправитель и его адрес: "+
ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОПоставщике,  "СокращенноеНаименование,ЮридическийАдрес,");
Предлагаю полный ИТ сервис небольшой организации в Москве (приходящий сисадмин+1С7.7,1С8.x)

Оффлайн Dimonxsl

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Ученик 1С
AntonB, Спасибо огромнейшее!!!! Все получилось - то что нужно!!!!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5553
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4373
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
41 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal