Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сопоставить разные типы регистров?  (Прочитано 3125 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Пишу обработку, кот создает док-т "Корр-ка записей регистров накопления"и заполнит регистр накопления "Расчет налоговых агентов с бюджетом по НДФЛ" на основаниии регистра накопления "НДФЛ расчеты с бюджетом".
Измерение регистра  Расчеты Налоговых агентов с бюджетом по НДФЛ- ПеречислениеСсылка.НДФЛСтавки,а у НДФЛ расчет с бюджетом-ПеречислениеСсылка.НДФЛСтавкиНалогообложенияРезидента.Как соспоставить значения разных типов?подскажите пожалуйста?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А в предыдущей теме об этом нельзя спросить?
Обязательно новую создавать? (


Выбираете записи из Регистра1.
Циклом их обходите.
Создаете записи в Регистре2.
Как доходите до полей с разными типами, вызывайте самописную функцию,
которая по значению Перечисления1 вернет значение Перечисления2...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Простите пожалуйста. спасибо за ответ.попробую

Оффлайн Михаил Сергеевич

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 3
  • КПД: 21%
  • Регистрация: 2011-03-15
  • Сайт: 
  • Профессия: Разработчик 1С
можно всё запросом сделать, засунуть в параметры таблицу соответствия и соединить

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
можно всё запросом сделать, засунуть в параметры таблицу соответствия и соединить

Согласен.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Функция СоответствиеРегистров()
   ПеречислениеСсылка.НДФЛСтавкиНалогообложенияРезидента=(ПеречислениеСсылка.НДФЛСтавки);
   НоваяЗапись.Поле=ПеречислениеСсылка.НДФЛСтавкиНалогообложенияРезидента;
   НоваяЗапись.Поле=(ПеречислениеСсылка.НДФЛСтавки);
    КонецФункции

Примерно так будет?и перед (ПеречислениеСсылка.НДФЛСтавки) какая функция должна быть?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Функция ПолучитьЗначениеПеречисления2(ЗначениеПеречисления1)

Если ЗначениеПеречисления1 = Перечисления.НДФЛСтавки.Значение1 Тогда
      Возврат Перечисления.НДФЛСтавкиНалогообложенияРезидента.Значение1;
ИначеЕсли ЗначениеПеречисления1 = Перечисления.НДФЛСтавки.Значение2 Тогда
      Возврат Перечисления.НДФЛСтавкиНалогообложенияРезидента.Значение2;
....и так далее...
КонецЕсли;

КонецФункции
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
попробовала.все равно пишет что ставка не заполнена. в каком еще месте можно посмотреть свою ошибку?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
СоответствиеЗначиний = Новый соответствие;
СоответствиеЗначиний.вставить("Значение1","Значение88");//Чему равно значение одного перечисления (Значение1) другого перечисления (Значение88)
СоответствиеЗначиний.Вставить("Значение2","Значение77");
Пока Выборка.Следующий() Цикл
ПеречислениеДляЗаполнения = Перечисления.НДФЛСтавкиНалогообложенияРезидента[СоответствиеЗначиний[Выборка.Твоеперечисление]];
КонецЦикла;
//Но лучший способ - это сугубо мое мнение, все таки через запрос это сделать сразу. прямо в запросе описать соответствие или же подсунуть как параметр.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Процедура СоздатьДОкументКорректировки()
   
   НовДокКоррЗап=Документы.КорректировкаЗаписейРегистровНакопления.СоздатьДокумент();
   НовДокКоррЗап.Дата=ТекущаяДата();
   ДвиженияКорр=НовДокКоррЗап.Движения;
   
   НовСтрРег=НовДокКоррЗап.ТаблицаРегистровНакопления.Добавить();
   НовСтрРег.Имя="РасчетыНалоговыхАгентовСБюджетомПоНДФЛ";
   НовСтрРег.Представление="Расчеты налоговых агентов с бюджетом по НДФЛ";
   РасчетыНалоговыхАгентовСБюджетомПоНДФЛДв=ДвиженияКорр.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ;
   НовДокКоррЗап.Записать();
      
   Запрос = Новый Запрос;
   Запрос.Текст =
    "ВЫБРАТЬ
    |   НДФЛРасчетыСБюджетом.Активность,
    |   НДФЛРасчетыСБюджетом.ВидДвижения,
    |   НДФЛРасчетыСБюджетом.Организация,
    |   НДФЛРасчетыСБюджетом.СтавкаНалогообложенияРезидента,
    |   НДФЛРасчетыСБюджетом.Налог,
    |   НДФЛРасчетыСБюджетом.КодПоОКАТО,
    |   НДФЛРасчетыСБюджетом.Период,
    |   НДФЛРасчетыСБюджетом.МесяцНалоговогоПериода,
    |   НДФЛРасчетыСБюджетом.ФизЛицо.Ссылка,
    |   НДФЛРасчетыСБюджетом.ФизЛицо
    |ИЗ
    |   РегистрНакопления.НДФЛРасчетыСБюджетом КАК НДФЛРасчетыСБюджетом" ;
    //|ГДЕ
    //|   НДФЛРасчетыСБюджетом.МесяцНалоговогоПериода = &Пер
    //|   И НДФЛРасчетыСБюджетом.Организация.Ссылка = &Орг";
   
    Результат=Запрос.Выполнить();
    Выборка=Результат.Выбрать();
   
   Пока Выборка.Следующий() Цикл
   НаборЗаписей = РегистрыНакопления.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.СоздатьНаборЗаписей();
   НаборЗаписей.Отбор.Регистратор.Установить(НовДокКоррЗап.Ссылка);
   НаборЗаписей.Прочитать();                                                                                 
    НоваяЗапись = НаборЗаписей.Добавить();
   //НоваяЗапись.Период = Выборка.НДФЛРасчетыСБюджетом.Период;
   НоваяЗапись.Активность=Истина;
   НоваяЗапись.МесяцНалоговогоПериода =Выборка.МесяцНалоговогоПериода;
   НоваяЗапись.ФизЛицо =Выборка.ФизЛицо;
   //НоваяЗапись.Ставка =Выборка.СтавкаНалогообложенияРезидента;
   НоваяЗапись.Ставка=Перечисления.НДФЛСтавкиНалогообложенияРезидента[Строка(Выборка.СтавкаНалогообложенияРезидента)];
   НоваяЗапись.Ставка=Выборка.СтавкаНалогообложенияРезидента;
   НоваяЗапись.ОКАТО_КПП =Выборка.КодПоОКАТО;
   НоваяЗапись.Организация=Выборка.Организация;
   
   
   НаборЗаписей.Записать();
     КонецЦикла;
      КонецПроцедуры
//
 Функция ПолучитьЗначениеПеречисления2(СтавкаНалогообложенияРезидента)

Если СтавкаНалогообложенияРезидента = Перечисления.НДФЛСтавкиНалогообложенияРезидента.Ставка09 Тогда
Возврат Перечисления.НДФЛСтавки.Ставка09;
ИначеЕсли СтавкаНалогообложенияРезидента = Перечисления.НДФЛСтавкиНалогообложенияРезидента.Ставка13 Тогда
Возврат Перечисления.НДФЛСтавки.Ставка13;
КонецЕсли;

КонецФункции


я так делала.попробую через соответствия.спасибо


Теги:
 

Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2134
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
Как обойти все регистры сведений и вывести список регистров в которых нет регистратора

Автор Alex117-117Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 982
Последний ответ 27 Апр 2016, 11:38
от cska-fanat-kz
Медленная работа регистров бухгалтерии в клиент-сереверном варианте 1С 8.2

Автор sektetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1849
Последний ответ 25 Янв 2011, 13:06
от sektet
8.3 RLS. Как настроить, если права берутся из двух регистров сведений

Автор HollyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1195
Последний ответ 24 Дек 2015, 12:59
от vitasw
1С 8.2 УПП 1.3.16.1 - Разные суммы в евро формируются в ТОРГ-12 и счет-фактуре

Автор ymarchРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4304
Последний ответ 25 Сен 2011, 07:05
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 327
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal