Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 окт 2021, 23:17

Создание элемента справочника из документа

Автор ich13, 02 июн 2009, 13:34

0 Пользователей и 1 гость просматривают эту тему.

ich13

Господа, подскажите новичку

Необходимо из табличной части формы документа создать (в случае если она отсудствует) позицию в справочнике (номенклатура) , и создать эту позицию нужно в выбираемой в этой же табличной части подгруппе вышеупомянутого справочника. 
Будте добры укажите что не так я написал касательно первой части проблеммы (не работает!  - при вводе данных в соответствующую ячейку таб. части выскакивает сообщение "Введены некорректные данные"), и что следует использовать что бы релизовать запись в выбираемую подгрупу.

Заранее спасибо.

Основной модуль


Функция НайтиПоНаименованию(Наименование) Экспорт
         С=Справочники.Номенклатура.СоздатьЭлемент();
    Если 
   С.НайтиПоНаименованию(Наименование,1,Справочники.Номенклатура)=0
      Тогда
      С.Наименование=Наименование;
        С.Записать();
           Сообщить(" Создан новый элемент: "+Наименование");
     КонецЕсли;
     Возврат(С.ТекущийЭлемент());
КонецФункции


Модуль формы

Процедура НаименованияНаименованиеПриИзменении(Наименование);
   НайтиПоНаименованию(Наименование);
КонецПроцедуры




Yura063

НайтиПоНаименованию() - возвращает тебе наименование которое он нашел,а не 0 или 1.
Помогли, отблагодари!

cska-fanat-kz

Алгоритм немного другой...
Сперва ищешь по наименованию, а затем если вернуло НЕОПРЕДЕЛЕНО (элемент не найден),
то создаешь новый...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

СветланаCC

Цитата: ich13 от 02 июн 2009, 13:34
Господа, подскажите новичку

Необходимо из табличной части формы документа создать (в случае если она отсудствует) позицию в справочнике (номенклатура) , и создать эту позицию нужно в выбираемой в этой же табличной части подгруппе вышеупомянутого справочника.

Заранее спасибо.
То есть в документе указан родитель так?
Получается, создаете функцию "Функция НайтиПоНаименованию(Наименование)"
В ней ищете в справочнике по наименованию номенклатуру если нашли - возвращаете ссылку на объект справочника, если нет то создаете новый элемент, возвращаете ссылку на созданный объект.
Тазовод)

СветланаCC

А насчет заданного родителя - при создании нового элемента просто прописываешь родителя
Тазовод)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск