Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 15:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание элемента справочника из документа  (Прочитано 3382 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ich13

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-06-02
  • Сайт: 
Господа, подскажите новичку

Необходимо из табличной части формы документа создать (в случае если она отсудствует) позицию в справочнике (номенклатура) , и создать эту позицию нужно в выбираемой в этой же табличной части подгруппе вышеупомянутого справочника. 
Будте добры укажите что не так я написал касательно первой части проблеммы (не работает!  - при вводе данных в соответствующую ячейку таб. части выскакивает сообщение “Введены некорректные данные“), и что следует использовать что бы релизовать запись в выбираемую подгрупу.

Заранее спасибо.

Основной модуль


Функция НайтиПоНаименованию(Наименование) Экспорт
         С=Справочники.Номенклатура.СоздатьЭлемент();
    Если 
   С.НайтиПоНаименованию(Наименование,1,Справочники.Номенклатура)=0
      Тогда
      С.Наименование=Наименование;
        С.Записать();
           Сообщить(" Создан новый элемент: "+Наименование");
     КонецЕсли;
     Возврат(С.ТекущийЭлемент());
 КонецФункции


Модуль формы

Процедура НаименованияНаименованиеПриИзменении(Наименование);
   НайтиПоНаименованию(Наименование);
КонецПроцедуры





Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
НайтиПоНаименованию() - возвращает тебе наименование которое он нашел,а не 0 или 1.
Помогли, отблагодари!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Алгоритм немного другой...
Сперва ищешь по наименованию, а затем если вернуло НЕОПРЕДЕЛЕНО (элемент не найден),
то создаешь новый...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Господа, подскажите новичку

Необходимо из табличной части формы документа создать (в случае если она отсудствует) позицию в справочнике (номенклатура) , и создать эту позицию нужно в выбираемой в этой же табличной части подгруппе вышеупомянутого справочника.

Заранее спасибо.
То есть в документе указан родитель так?
Получается, создаете функцию "Функция НайтиПоНаименованию(Наименование)"
В ней ищете в справочнике по наименованию номенклатуру если нашли - возвращаете ссылку на объект справочника, если нет то создаете новый элемент, возвращаете ссылку на созданный объект.
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
А насчет заданного родителя - при создании нового элемента просто прописываешь родителя
Тазовод)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4483
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15964
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7758
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4789
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1596
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal