Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установить префиксы номеров документов.  (Прочитано 18261 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Конфигурация Бухгалтерия предприятия, редакция 2.0
Подскажите, как установить префиксы номеров только у счёт фактур и актов?
Пробовал так:

Процедура УстановитьНомерДокумента(ДокументОбъект) Экспорт     

   // Если  нет реквизита "Организация" или для нее не задан префикс, то
   // используем пустой префикс,
   // иначе используем префикс организации.
МетаданныеДокумента = ДокументОбъект.Метаданные();
   Если (ДокументОбъект.Метаданные().Имя = "АктОбОказанииПроизводственныхУслуг") Или (ДокументОбъект.Метаданные().Имя = "АктСверкиВзаиморасчетов") Или (ДокументОбъект.Метаданные().Имя = "СчетФактураВыданный") Или (ДокументОбъект.Метаданные().Имя = "СчетФактураПолученный") Тогда // Ширшов П.С. Энима

      Если Не ЕстьРеквизитДокумента("Организация", МетаданныеДокумента)
         ИЛИ НЕ ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс)  Тогда
         Префикс = Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""") // Ширшов П.С. Энима
      Иначе
         
         Префикс = ДокументОбъект.Организация.Префикс + Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""");                 
         
      КонецЕсли;
   Иначе
      Если Не ЕстьРеквизитДокумента("Организация", МетаданныеДокумента)
         Или НЕ ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс) Тогда
         
         ДокументОбъект.УстановитьНовыйНомер("00");
         
      Иначе
         
         ДокументОбъект.УстановитьНовыйНомер(ДокументОбъект.Организация.Префикс);
         
      КонецЕсли;
   КонецЕсли;
   
   Если ЕстьРеквизитДокумента("НДСВключенВСтоимость", МетаданныеДокумента) И
      ЕстьРеквизитДокумента("Организация", МетаданныеДокумента) Тогда
      Если НалоговыйУчетУСН.ПрименениеУСН(ДокументОбъект.Организация, ДокументОбъект.Дата) Тогда
         ДокументОбъект.НДСВключенВСтоимость = Истина;
      КонецЕсли;
   КонецЕсли;


КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
1C просто вылетает при записи документов, не являющихся счётом-фактурой или актом :(

Оффлайн steptostep

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2009-11-22
  • Сайт: 
   Если ЕстьРеквизитДокумента("НДСВключенВСтоимость", МетаданныеДокумента) И
      ЕстьРеквизитДокумента("Организация", МетаданныеДокумента) Тогда
      Если НалоговыйУчетУСН.ПрименениеУСН(ДокументОбъект.Организация, ДокументОбъект.Дата) Тогда
         ДокументОбъект.НДСВключенВСтоимость = Истина;
      КонецЕсли;
   КонецЕсли; - зачем этот кусок кода здесь?

Оффлайн steptostep

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2009-11-22
  • Сайт: 
А в отладчике посмотреть на каком операторе вылетает программа?

Оффлайн steptostep

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2009-11-22
  • Сайт: 
Кстати, не хватает ДокументОбъект.УстановитьНовыйНомер(Префикс);
после кода
      Если Не ЕстьРеквизитДокумента("Организация", МетаданныеДокумента)
         ИЛИ НЕ ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс)  Тогда
         Префикс = Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""") // Ширшов П.С. Энима
      Иначе
         
         Префикс = ДокументОбъект.Организация.Префикс + Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""");                 
         
      КонецЕсли;

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
А в отладчике посмотреть на каком операторе вылетает программа?
Зацикливается в процедуре

Процедура ДобавитьПрефиксОрганизацииИДаты(ДокументОбъект, Префикс) Экспорт   

   
   // Если  нет реквизита "Организация" или для нее не задан префикс, то
   // используем пустой префикс,
   // иначе используем префикс организации.
   МетаданныеДокумента = ДокументОбъект.Метаданные();
   Если (ДокументОбъект.Метаданные().Имя = "АктОбОказанииПроизводственныхУслуг") Или (ДокументОбъект.Метаданные().Имя = "АктСверкиВзаиморасчетов") Или (ДокументОбъект.Метаданные().Имя = "СчетФактураВыданный") Или (ДокументОбъект.Метаданные().Имя = "СчетФактураПолученный") Тогда         

      Если Не ЕстьРеквизитДокумента("Организация", МетаданныеДокумента)
         ИЛИ НЕ ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс)  Тогда
         Префикс = Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""")
      Иначе
         
         Префикс = ДокументОбъект.Организация.Префикс + Формат(ДокументОбъект.Дата,"ДФ=""ггггММ""");                   
         
      КонецЕсли;
      ДокументОбъект.УстановитьНовыйНомер(Префикс);
   Иначе
      Если Не ЕстьРеквизитДокумента("Организация", МетаданныеДокумента)
         Или НЕ ЗначениеЗаполнено(ДокументОбъект.Организация.Префикс) Тогда
         
         ДокументОбъект.УстановитьНовыйНомер("00");
         
      Иначе
         Префикс = ДокументОбъект.Организация.Префикс;
         ДокументОбъект.УстановитьНовыйНомер(Префикс);
         
      КонецЕсли;
   КонецЕсли;
   
   Если ЕстьРеквизитДокумента("НДСВключенВСтоимость", МетаданныеДокумента) И
      ЕстьРеквизитДокумента("Организация", МетаданныеДокумента) Тогда
      Если НалоговыйУчетУСН.ПрименениеУСН(ДокументОбъект.Организация, ДокументОбъект.Дата) Тогда
         ДокументОбъект.НДСВключенВСтоимость = Истина;
      КонецЕсли;
   КонецЕсли;
   
Конецпроцедуры

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Блин, я вызываю эту процедуру в обработчике при установке нового номера))
Вот она и зацикливается)
Как исправить?

Оффлайн steptostep

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2009-11-22
  • Сайт: 
Использовать подписку на событие - с отказом от стандартной обработки

Оффлайн 556008

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Спасибо, про подписки вообще не знал, начинающий ещё


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3178
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4094
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 171
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3020
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1784
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 234
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal