Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 17:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Можно ли узнать размер файла до копирования на сервер?  (Прочитано 6500 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн KrutoyGeniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-18
  • Сайт: 
  • Профессия: Программист 8.1
В веб клиенте при использовании функция ПоместитьФайл() файл на веб клиенте копируется на сервер.
Если НЕ ПоместитьФайл(ФайлАдрес, ИмяФайла, ИмяФайла, Истина) Тогда
 Возврат;
КонецЕсли;

Чтобы узнать размер файла изпользую

Файл = Новый Файл(ИмяФайла);
РазмерФайла = Файл.Размер();

Но это уж после копирования файла на сервер.
Попробовал вот так

ФайлВыбор = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Результат = ФайлВыбор.Выбрать();
Если НЕ Результат Тогда
 Возврат Ложь;
КонецЕсли;
ИмяФайла = ФайлВыбор.ПольноеИмяФайла
НовыйФайл = Новый Файл(ИмяФайла);
РазмерФайла = НовыйФайл.Размер();


Если НЕ ПоместитьФайл(ФайлАдрес, ИмяФайла, ИмяФайла, Истина) Тогда
 Возврат;
КонецЕсли;

Получилось узнать размер файла, но при выполнение  ПоместитьФайл() ешё показывается диалог выбора файла.


Можно ли узнать размер файла до копирования на сервер?


Оффлайн KrutoyGeniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-18
  • Сайт: 
  • Профессия: Программист 8.1

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот так:
Файл = Новый Файл(ИмяФайла);
РазмерФайла = Файл.Размер();

Но это уж после копирования файла на сервер.
Попробовал вот так

ФайлВыбор = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Результат = ФайлВыбор.Выбрать();
Если НЕ Результат Тогда
 Возврат Ложь;
КонецЕсли;
ИмяФайла = ФайлВыбор.ПольноеИмяФайла
НовыйФайл = Новый Файл(ИмяФайла);
РазмерФайла = НовыйФайл.Размер();


Если НЕ ПоместитьФайл(ФайлАдрес, ИмяФайла, ИмяФайла, Ложь) Тогда
 Возврат;
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн KrutoyGeniy

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-18
  • Сайт: 
  • Профессия: Программист 8.1
Ошибка вышло!
{ФайлларБиланИшлашКлиент(102)}: Ошибка при вызове метода контекста (ПоместитьФайл)
   Если НЕ ПоместитьФайл(ФайлАдрес, ИмяФайла, ИмяФайла, Ложь) Тогда
по причине:
{ФайлларБиланИшлашКлиент(102)}: В веб-клиенте доступен только интерактивный режим

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Где то на этом форуме уже было обсуждение работы с файлами в Веб-Клиенте
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если не ошибаюсь то через ПоместитьФайлы() в Веб-Клиенте возможен вызов не интерективно
ПоместитьФайлы (PutFiles)
Синтаксис:

ПоместитьФайлы(<ПомещаемыеФайлы>, <ПомещенныеФайлы>, <НаборПомещаемыхФайлов>, <Интерактивно>, <УникальныйИдентификаторФормы>)
Параметры:

<ПомещаемыеФайлы> (необязательный)

Тип: Массив.
Массив объектов типа ОписаниеПередаваемогоФайла.
Каждый объект описывает получаемый файл:
Хранение - расположение данных во временном хранилище;
Имя - это локальный путь, по которому должен быть получен файл.
Массив может быть заполнен полностью, в этом случае известен набор помещаемых файлов и адреса, по которым они должны быть сохранены.
Массив может быть заполнен частично, у элементов массива заполнены только имена. В этом случае, набор помещаемых файлов определен, а места хранения не известны. Файлы будут размещены в новых временных хранилищах.
Массив может быть не заполнен. В этом случае набор помещаемых файлов определяется по значениям остальных параметров метода (поиском по маске, либо интерактивным выбором).
<ПомещенныеФайлы> (необязательный)

Тип: Массив.
Массив объектов типа ОписаниеПереданногоФайла.
Каждый объект описывает помещенный файл:
Хранение - расположение данных во временном хранилище;
Имя - это локальный путь, по которому получен файл.
<НаборПомещаемыхФайлов> (необязательный)

Тип: ДиалогВыбораФайла; Строка.
Определяет набор помещаемых файлов.
Может быть задан строкой поиска для метода НайтиФайлы, либо, заранее подготовленным, диалогом выбора файлов в режиме открытия файлов.
Если параметр определен, то параметр <ПомещаемыеФайлы> должен быть не определен либо быть пустым массивом.
<Интерактивно> (необязательный)

Тип: Булево.
Указывает использование интерактивного режима, при котором пользователю показывается диалог, в котором он может выбрать набор помещаемых файлов.
<УникальныйИдентификаторФормы> (необязательный)

Тип: УникальныйИдентификатор.
Уникальный идентификатор формы, который можно получить с помощью свойства УникальныйИдентификатор управляемой формы.
Файл помещается во временное хранилище и автоматически удаляется после удаление объекта формы.
Если параметр не указан, помещенное значение будет удалено, после очередного запроса сервера из общего модуля, при контекстном и неконтекстном серверном вызове из формы, при серверном вызове из модуля команды или при получении формы.
Возвращаемое значение:

Тип: Булево.

Описание:

Помещает набор файлов из локальной файловой системы во временное хранилище.

Доступность:

Тонкий клиент, веб-клиент, толстый клиент.
Примечание:

Для работы метода на веб-клиенте, необходимо предварительно подключить расширение работы с файлами.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4298
Последний ответ 24 Дек 2015, 15:34
от дфтын
УНФ планировщик выдает на план-графике вместо контрагентов <Точка 1>, <Точка 2> и т.д. Как можно отобразить наименования контрагентов вместо точек?

Автор olesya9393Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 495
Последний ответ 09 Янв 2017, 12:55
от olesya9393
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9362
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Справочник "Сотрудники" можно просматривать

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3340
Последний ответ 03 Фев 2014, 11:50
от Alex56
Расходы на чай сотрудникам можно списать в налоговые расходы

Автор newsРаздел Новости

Ответов: 0
Просмотров: 2166
Последний ответ 31 Июл 2014, 12:19
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal