Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с запросом!  (Прочитано 2301 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dwarf33

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-17
  • Сайт: 
  • Профессия: Программист 8.1
Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("Организация",Организация);
      Запрос.УстановитьПараметр("Дата",Дата);
      Запрос.Текст = "ВЫБРАТЬ
                     |       
                     |   НДСПредъявленныйОстатки.ВидЦенности КАК ВидЦенности,
                     |   НДСПредъявленныйОстатки.Поставщик КАК Поставщик,
                     |   НДСПредъявленныйОстатки.СчетФактура КАК СчетФактура,
                     |   НДСПредъявленныйОстатки.НДСОстаток КАК НДСОстаток,
                     |   НДСПредъявленныйОстатки.СчетУчетаНДС КАК СчетУчетаНДС
                     |ИЗ
                     |   РегистрНакопления.НДСПредъявленный.Остатки КАК НДСПредъявленныйОстатки
                     | ";
Результ = Запрос.Выполнить().Выбрать();            
            
        Пока Результ.Следующий() Цикл
         
         НСтр = НДСКВосстановлению.Добавить();
         Нстр.ВидЦенности = Результ.ВидЦенности;
         Нстр.Поставщик = Результ.Поставщик;
         НСтр.СчетФактура = Результ.СчетФактура;
         НСтр.НДСОстаток = результ.НДСОстаток;
         НСтр.СчетУчетаНДС = Результ.СчетУчетаНДС;
      
      КонецЦикла;   
Вопрос: Запрос работает! Но выводит данные за 10 месяц 2011 года. Как сделать что бы он выводил данные за  2 года? Заранее благодарен!


Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
А где условие?

Усё чотко!

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
ТипаЭтого:
                    |ИЗ
                     |   РегистрНакопления.НДСПредъявленный.Остатки(&дата, ) КАК НДСПредъявленныйОстатки
                     |ГДЕ
                     |   РегистрНакопления.Организация = &Организация  ";
Усё чотко!

Оффлайн Dwarf33

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-17
  • Сайт: 
  • Профессия: Программист 8.1
Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("Организация",Организация);
      Запрос.УстановитьПараметр("Дата",Дата);
      Запрос.Текст = "  Выбрать
      
                |   НДСПредъявленныйОстатки.ВидЦенности КАК ВидЦенности,
                     |   НДСПредъявленныйОстатки.Поставщик КАК Поставщик,
                     |   НДСПредъявленныйОстатки.СчетФактура КАК СчетФактура,
                     |   НДСПредъявленныйОстатки.НДСОстаток КАК НДСОстаток
                     |ИЗ
                     |   РегистрНакопления.НДСПредъявленный.Остатки(&Дата, ) КАК НДСПредъявленныйОстатки
                |Где
                |   РегистрНакопления.Организация = &Организация";
 Результ = Запрос.Выполнить().Выбрать();            
            
        Пока Результ.Следующий() Цикл
         
         НСтр = НДСКВосстановлению.Добавить();
         Нстр.ВидЦенности = Результ.ВидЦенности;
         Нстр.Поставщик = Результ.Поставщик;
         НСтр.СчетФактура = Результ.СчетФактура;
         НСтр.НДСОстаток = результ.НДСОстаток;
      КонецЦикла;   


Теперь выдает ошибку:
{Форма.Форма.Форма(110)}: Ошибка при вызове метода контекста (Выполнить)
   Результ = Запрос.Выполнить().Выбрать();            
по причине:

по причине:
{(9, 2)}: Поле не найдено "РегистрНакопления.Организация"
<<?>>РегистрНакопления.Организация = &Организация

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ   
 |   НДСПредъявленныйОстатки.ВидЦенности КАК ВидЦенности,
 |   НДСПредъявленныйОстатки.Поставщик КАК Поставщик,
 |   НДСПредъявленныйОстатки.СчетФактура КАК СчетФактура,
 |   НДСПредъявленныйОстатки.НДСОстаток КАК НДСОстаток
 |ИЗ
 |   РегистрНакопления.НДСПредъявленный.Остатки(&НачПериода,КонПериода,,, Организация = &Организация ) КАК НДСПредъявленныйОстатки";

Запрос.УстановитьПараметр("Организация",Организация);
Запрос.УстановитьПараметр("НачПериода",НачалоПериода);
Запрос.УстановитьПараметр("КонПериода",КонецПериода);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий () Цикл
  // тут пишите что Вам надо получить в результате
КонецЦикла;

Если вы начинающий программист тогда было бы лучше постараться написать самим,
ведь основой работы по отбору данных на платформе 1С-Предприятие 8.х являются запросы. Совететую для начала установить себе консольку, по личному опуту знаю!

 
Усё чотко!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ   
 |   НДСПредъявленныйОстатки.ВидЦенности КАК ВидЦенности,
 |   НДСПредъявленныйОстатки.Поставщик КАК Поставщик,
 |   НДСПредъявленныйОстатки.СчетФактура КАК СчетФактура,
 |   НДСПредъявленныйОстатки.НДСОстаток КАК НДСОстаток
 |ИЗ
 |   РегистрНакопления.НДСПредъявленный.Остатки(&НачПериода,КонПериода,,, Организация = &Организация ) КАК НДСПредъявленныйОстатки";

Запрос.УстановитьПараметр("Организация",Организация);
Запрос.УстановитьПараметр("НачПериода",НачалоПериода);
Запрос.УстановитьПараметр("КонПериода",КонецПериода);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий () Цикл
  // тут пишите что Вам надо получить в результате
КонецЦикла;

Если вы начинающий программист тогда было бы лучше постараться написать самим,
ведь основой работы по отбору данных на платформе 1С-Предприятие 8.х являются запросы. Совететую для начала установить себе консольку, по личному опуту знаю!

 



В виртуальной таблице ОСТАТКОВ - ПЕРИОД (НачалоПериода, КонецПериода)?
Ну ну...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Шурик_1985

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 5
  • КПД: 11%
  • )
  • Регистрация: 2011-05-14
  • Сайт: 
  • Профессия: Ученик 1С
аа точно обороты:))
Усё чотко!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4300
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5556
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5895
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4381
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1982
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 117
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal