Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 16:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Посоветуйте как скинуть прайс номенклатуры из Excel в УТ 11  (Прочитано 5238 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ленок87

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте. Очень нужен ваш совет ( начинающий программист,строго не судите если что не так) .Нужно скинуть прайс номенклатуры из Excel в УТ 11 пробую запустить файл "Загрузка файлов из табличной части" открывается пустое окно,хотя в конфигураторе все(вроде) нормально.


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
А что ты хочешь куда добавить? В номенклатуру поставщика?
Помогли, отблагодари!

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Функция ЗагрузкаИзExcel(ИмяФайла)

    //Номер листа в книге Excel для получения данных
    НомерЛиста         = "НомерЛиста";
    //Пытаемся подключиться к Excel
    Попытка
        Excel = новый COMОбъект("Excel.Application");
    Исключение
        Сообщить("Похоже, Excel на компьютере не установлен. Необходимо выполнить установку/переустановку Excel.");
        Возврат Ложь;
    КонецПопытки;     
    //Подключились удачно, открываем файл
    Excel.Workbooks.Open(ИмяФайла);
    //Открываем необходимый лист
    Excel.Sheets(НомерЛиста).select();   
    //Получим количество строк и колонок.
    //В разных версиях Excel получаются по-разному, поэтому сначала определим версию Excel
    Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);
    Если Версия = "8" тогда
        ФайлСтрок   = Excel.Cells.CurrentRegion.Rows.Count;
        ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 12);
    Иначе
        ФайлСтрок   = Excel.Cells(1,1).SpecialCells(11).Row;
        ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;   
    Конецесли;
    // Выбираем данные из файла
// Ввод ВидаНоменклатуры

Для а = 2 по ФайлСтрок Цикл           
//Получим данные из соответсвующих ячеек
Номенклатура = Справочники.ВидыНоменклатуры.СоздатьЭлемент();
  Номенклатура.Наименование = СокрЛП(Excel.Cells(а,1).Value);
Номенклатура.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
Номенклатура.ИспользоватьХарактеристики = Истина;
Номенклатура.ИспользованиеХарактеристик = Перечисления.
ВариантыВеденияДополнительныхДанныхПоНоменклатуре.ИндивидуальныеДляНоменклатуры;
Номенклатура.Записать();
КонецЕсли;
  КонецЕсли;
Конеццикла;
    Excel.ActiveWorkbook.Close();   
КонецФункции

вставляй свои условия, выбирай справочник и вперед!!!
Помогли, отблагодари!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Загрузка номенклатуры из Excel в УТ

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
AIFrame
69 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 847
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal