Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать ценника из поступление тмц розница.  (Прочитано 3600 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Андрей19986

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-02
  • Сайт: 
  • Профессия: Ученик 1С
1c тис
Платформа 7.7 (7.70.027)
Конфигурация  ТиС (Торговля и склад) (7.70.945)



Доброго времени суток. Прошу помощи. Как в данную обрабоку добавить вывод страны происхождения из документа поступление тмц розница на ценник. В данной обработке она отсутствует вообще. Заранее благодарен.


Перем ПечФирма;

//******************************************************************************
// ДобавитьЦенник(Таб, Фирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
//
// Параметры:
//  Таб             - таблица, в которую выполняется вывод ценника
//  ПечНаименование - наименование ТМЦ
//  ПечЕдиница      - единица измерения ТМЦ
//  ПечРозн         - цена ТМЦ
//  Столбик         - номер столбика.
//  Ряд             - номер ряда
//
// Возвращаемое значение:
//  Нет.
//
// Описание:
//  Добавляет ценник в таблицу.
//
Процедура ДобавитьЦенник(Таб, Фирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд) Экспорт
       
   Столбик   = ?(Столбик = 0, 1      , 0  );
   Ряд      = ?(Столбик = 0, Ряд + 1, Ряд);

   Если Ряд > 5 Тогда
       Таб.НоваяСтраница();
       Ряд = 1;
    КонецЕсли;
    
    Если Столбик = 0 Тогда
       Таб.ВывестиСекцию("Товар|Ценник");
    Иначе
       Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли;

КонецПроцедуры // ДобавитьЦенник()

//******************************************************************************
// Печать(Докум, Устройство=0, КолвоКопий=1)
//
// Параметры:
//  Докум      - контекст выводимого документа (ПереоценкаРозница, ПоступлениеТМЦРозница),
//  Устройство - если 0, то вывод на экран, иначе - на принтер,
//               необязателен, по умолчанию - на экран,
//  КолвоКопий - количество копий, по умолчанию - 1.
//
// Возвращаемое значение:
//  Нет
//
// Описание:
//  Формирует таблицу с ценниками.
//
Процедура Печать(Докум, Устройство=0, КолвоКопий=1)
   
   ДокумВид = Докум.Вид();
   Если ДокумВид = "ПереоценкаРозница" Тогда
      ИдРознЦена = "ЦенаНовая";
   ИначеЕсли ДокумВид = "ПоступлениеТМЦРозница" Тогда
      ИдРознЦена = "РозничнаяЦена";
   ИначеЕсли ДокумВид = "ПеремещениеТМЦ" Тогда
      Если Докум.СкладПолучатель.РозничныйСклад = 1 Тогда
         ИдРознЦена = "Цена";
      Иначе
         Предупреждение("Нельзя печатать ценники при перемещении
                        |ТМЦ на оптовый склад!", 60);
         Возврат;   
      КонецЕсли;
   Иначе
      Возврат;   
   КонецЕсли;
   
   //  Создание Таблицы для выходного отчета
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
   
   ПечФирма = СокрЛП(Докум.Фирма.ЮрЛицо.ПолнНаименование);
    
   Столбик = 1;
    Ряд     = 0;
    
    Докум.ВыбратьСтроки();
    Пока Докум.ПолучитьСтроку() = 1 Цикл
      Если ДокумВид = "ПереоценкаРозница" Тогда // пропускаем ТМЦ, где цена не менялась
          Если Докум.ЦенаСтарая = Докум.ЦенаНовая Тогда
             Продолжить;   
          КонецЕсли;
       КонецЕсли;
       ВремЦена = Докум.ПолучитьАтрибут(ИдРознЦена);
      ПечРозн    = глФРМ(ВремЦена, глРубли); // печатаем по розничным ценам - поэтому глРубли
      ПечНаименованиеТМЦ = СокрЛП(Докум.Номенклатура.ПолнНаименование) + ?(Константа.ПоказыватьАртикул = 1, " " + СокрЛП(Докум.Номенклатура.Артикул), "");
      ДобавитьЦенник(Таб, Докум.Фирма, ПечНаименованиеТМЦ, Докум.Единица, ПечРозн, Столбик, Ряд);
       глОживить(1);
   КонецЦикла;
    
   Если Устройство = 0 Тогда
      Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
      Таб.ТолькоПросмотр(1);
      Таб.Показать("Товарные ценники","");
   Иначе     
      Таб.ПараметрыСтраницы(,,,,,,,,,1,,);
      Таб.КоличествоЭкземпляров(КолвоКопий);
      Таб.Напечатать(0);
   КонецЕсли;
   
КонецПроцедуры // Печать()

//******************************************************************************
// ПоКнопкеПечать()
//
// Параметры:
//  Нет
//
// Возвращаемое значение:
//  Нет
//
// Вызывается из формул элементов диалога:
//  Кнопка "Печать"
//
// Описание:
//
Процедура ПоКнопкеПечать()
   
   Если Док.Выбран() = 0 Тогда
       Предупреждение("Не выбран документ!", 60);
      Возврат;
   КонецЕсли;
   
   Печать(Док);
   
КонецПроцедуры // ПоКнопкеПечать()

//******************************************************************************
// Предопределенная процедура
//
Процедура ПриОткрытии()
   
   Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
      
      Докум      = Форма.Параметр.Получить("Контекст");
      Устройство = Форма.Параметр.Получить("Устройство");
      КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
   
      Печать(Докум, Устройство, КолвоКопий);
      Статусвозврата(0);
      Возврат;
   КонецЕсли;
   
КонецПроцедуры // ПриОткрытии()


Оффлайн Андрей19986

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-02
  • Сайт: 
  • Профессия: Ученик 1С
Ни зная ни языка програмирования ни програмы толком, сам разобрался, и сам доволен. И как большенство на этом сайте, я ни кому ни чего не скажу.Я же такой же жид как и все.

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Молодец, можешь взять пирожок с полки.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal