Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выдернуть тип Субконто счета?  (Прочитано 3391 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Givy

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-07
  • Сайт: 
  • Профессия: Программист 8.1
Нужно сделать функцию, которая выдернет тип Субконто счета нужного уровня

Функция ПолучитьВидСубконто(КодСчета, УровеньСубконто)
........
КонецФункции

Помогите, плз.
Вам задачка на пару секунд, а я уже голову сломал.
Если Вам кажется, что я задал слишком простой и тупой вопрос, значит так и есть.
Все равно ответьте, я еще только учусь.


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Не пробовал, но может прокатит? Только не известен тип переменной КодСчета. Если тип ссылка, то
Функция ПолучитьВидСубконто(КодСчета, УровеньСубконто)
   Возврат КодСчета.ВидыСубконто[УровеньСубконто].ВидСубконто.ТипЗначения;
КонецФункции
если просто строка, то
Функция ПолучитьВидСубконто(КодСчета, УровеньСубконто)
   Возврат ПланыСчетов.Хозрасчетный.НайтиПоКоду(КодСчета).ВидыСубконто[УровеньСубконто].ВидСубконто.ТипЗначения;
КонецФункции

Оффлайн Givy

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-07
  • Сайт: 
  • Профессия: Программист 8.1
Тип переменной строка.
Пробовал по второму варианту, выдает ошибку "Индекс находится за границами массива"
Если Вам кажется, что я задал слишком простой и тупой вопрос, значит так и есть.
Все равно ответьте, я еще только учусь.

Оффлайн Givy

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-07
  • Сайт: 
  • Профессия: Программист 8.1
Разобрался. На некоторых счетах нет субконто такого уровня.
Спасибо.
Если Вам кажется, что я задал слишком простой и тупой вопрос, значит так и есть.
Все равно ответьте, я еще только учусь.


Теги:
 

Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3835
Последний ответ 24 Июл 2012, 05:02
от unanted
Не выгружается документ основания для счета фактуры с типом возврат, когда документ основание поступление выгружается, КД 2

Автор Алексей ГеннадьевичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 388
Последний ответ 21 Апр 2017, 04:55
от Алексей Геннадьевич
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Отчет "Обороты счета"

Автор evgeniy1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5562
Последний ответ 02 Апр 2013, 13:14
от Besart
Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4027
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 164
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal