Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 02:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохранить изменения....  (Прочитано 2240 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Помогите решить вопрос..
Модуль обмена лежит во вложении

При обмене заказами с сайтом происходит следующая невиданная вещь. Выгружаю заказы с проведением и проверкой на комментарий. Если есть комментарий то ОТменаПроведения... Все отлично, документы создаются, какие нужно проводятся какие не нужно не проводятся - все классно.
Однако при проводе заказа на стороне 1С и последующей синхронизации происходит буквально чудо... Только что проведенные заказы становятся распроведенными ?!?
Однако, если мы помечаем заказ на удаление, то пометка удаления не снимается при последующих синхронизациях...
В чем фишка???


Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурация 1С:Предприятие 8.2 (8.2.15.289) Ликероводочный и винный завод 1,3 !!!

Может быть стоит сделать так:
Если ДокументПроведения.Проведен = Истина Тогда
  ДокументПроведения.Записать(РежимЗаписиДокумента.Проведение, РежимПроведения);
КонецЕсли;

Однако данная проверка не срабатывает ((

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Или дело все в том, что:
РежимПроведения = ?(ПроводитьДокументыОперативно, РежимПроведенияДокумента.Оперативный, РежимПроведенияДокумента.Неоперативный);
Для Каждого ДокументПроведения Из МассивДокументовДляПроведения Цикл

Это цикл, и каждый раз при проверке на комментарий документ распроводится???
Если Найти(ДокументПроведения.Ссылка.Комментарий, ":") > 0 Тогда
   Сообщить("Есть комментарий "+ДокументПроведения);
   ДокументПроведения.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Продолжить;
КонецЕсли;

Тогда не понятно где происходит установка ПометкиУдаления??
И почему этот Цикл не трогает эту пометку ?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Тогда не понятно где происходит установка ПометкиУдаления??
В процедуре ПриЗаписи документа
Цитировать
И почему этот Цикл не трогает эту пометку ?
Тут не понятно, что значит не трогает?

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
has
Спасибо за совет, но из доступных вариантов записи есть только:
Процедура ЗаписатьCMLПоСпискуЗначений(ОбъектCML, СписокЗначений);
Процедура ЗаписатьИнформациюВПротоколОбмена(СтруктураИнформации)
Функция ЗаписатьСвойстваДокументов(ДеревоДокументов, СтруктураСтатистики, МассивОтклоненныхДокументов)
Процедура ЗаписатьТекстовойУзел(ОбъектXML, Имя, Значение, ОбязательнаяПроверкаНаПустуюСтроку = Истина)
А как таковой процедуры записи документа нет...(

А по поводу не трогает. Я имел в виду, что при ПометкеНаУдаление в 1С-ке и последующей синхронизации с ВебСайтом, эта пометка (На удаление) не снимается в отличие от "пометки" Проведения документа.
Мне вот интересно почему?

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Я понял в чем дело!!!!
Как раз в этой проверке:

Если Найти(ДокументПроведения.Ссылка.Комментарий, ":") > 0 Тогда
   Сообщить("Есть комментарий "+ДокументПроведения);
   ДокументПроведения.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Продолжить;
КонецЕсли;
Получается что документ при повторной синхронизации проходит опять эту проверку... и Отменяется проведение...!!!
Подскажите как это можно решить??! Сам ни как не допру.... :dfbbdrfb:
Может быть нужно как-то этот документ изъять из массива
МассивДокументовДляПроведения
??

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Друзья, в общем все оказалось в разы проще...
Всего лишь нужно было добавить в эту функцию:
Функция СоздатьОбновитьДокументы(ДеревоДокументов, СтруктураСтатистики, МассивДокументовДляПроведения, МассивЗагруженныхДокументов)
Вот такой вот код:
Если Док.РанееЗагруженныйДокументСсылка.Проведен Тогда
  СтруктураСтатистики.Пропущено = СтруктураСтатистики.Пропущено + 1;
  Продолжить;
КонецЕсли;
Соответственно при проведении заказа и последующем обмене галочка проведения не снимается!
Всем спасибо за поддержку )


Теги:
 

Функция "дата запрета изменения данных"

Автор carrotlassРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1169
Последний ответ 17 Май 2015, 01:31
от SitnovaMarina
1С8,3 ЗУП - Изменения документа "ОТПУСК" в текущем периоде

Автор Buh_SevasРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1743
Последний ответ 27 Июл 2015, 16:54
от pavl_vs
Как восстановить в ИБ запрет изменения с поддержкой (восстановить серый замочек)

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 998
Последний ответ 06 Июл 2016, 14:55
от ktu78
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6212
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
Документ "Корректировка реализации" изменения в релизе 3.0.36.18 в параметре Отражать корректировку

Автор gapp2009Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2115
Последний ответ 16 Дек 2014, 02:00
от gapp2009

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 188
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal