Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление истории  (Прочитано 7897 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Доброе время суток, подскажите пожалуйста как написать обработку, что бы история в справочнике на 31.01.2012 удалялась. Зарание благодарен 


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Удаление истории
« Ответ #1: 01 Фев 2012, 09:15 »
То есть почистить периодические реквизиты справочника за 31.01.12?? или все предыдущие почистить, а на 31.01.12 оставить?
Тазовод)

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Удаление истории
« Ответ #2: 01 Фев 2012, 09:21 »
нужно все предыдущие оставить, а на 31.01.12 очистить.
мои наработки, но не работает почему то :
Процедура Выполнить() 
   
    СпрН = СоздатьОбъект("Справочник.Нас_Население");
   СпрН.ВыбратьЭлементы();
   Пока СпрН.ПолучитьЭлемент() > 0 Цикл
      Если спрН.ЭтоГруппа() = 0 тогда
          Потребитель = СпрН.ТекущийЭлемент();
      Если Потребитель.Дом.ТипДома =  Перечисление.ТипДома.Многоэтажный Тогда
         МногНорм = СпрН.ИндМногоквартирная.Получить('31.12.2011');
         МногНорм.Удалить();
      КонецЕсли;
        КонецЕсли;
   КонецЦикла;    
КонецПроцедуры

пишет ошибку:
"ЗимНорм = СпрН.ИндЗимняяНорма.Получить('31.12.2011').удалить();
Значение не представляет агрегатный объект (удалить)"

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Удаление истории
« Ответ #3: 01 Фев 2012, 09:39 »
Удалить()
Синтаксис:
Удалить()
Назначение:
Удалить периодическое значение на заданную дату.
Возвращает: 1 - если вызов метода закончился успешно, 0 - иначе.
Замечание:
До вызова данного метода периодическое значение следует выбрать при помощи методов ПолучитьЗначение или НайтиЗначение.
Тазовод)

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Удаление истории
« Ответ #4: 01 Фев 2012, 09:47 »
т.е. будет выглядеть так МногНорм = СпрН.ИндМногоквартирная.ПолучитьЗначение('31.12.2011');

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Re: Удаление истории
« Ответ #5: 01 Фев 2012, 09:59 »
т.е. будет выглядеть так МногНорм = СпрН.ИндМногоквартирная.ПолучитьЗначение('31.12.2011');
попробуйте так, а в отладчике гляньте...
Тазовод)

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Удаление истории
« Ответ #6: 01 Фев 2012, 10:09 »
если вот такой код :
Процедура Выполнить() 
   
    СпрН = СоздатьОбъект("Справочник.Нас_Население");
   СпрН.ВыбратьЭлементы();
   Пока СпрН.ПолучитьЭлемент() > 0 Цикл
      Если спрН.ЭтоГруппа() = 0 тогда
          Потребитель = СпрН.ТекущийЭлемент();
        
      Если Потребитель.Дом.ТипДома =  Перечисление.ТипДома.Многоэтажный Тогда
         ЗимНорм = СпрН.ИндЗимняяНорма.Получить('31.12.2011');
          ЗимНорм.Удалить();
      КонецЕсли;
        КонецЕсли;
   КонецЦикла;    
КонецПроцедуры

Ошибка
ЗимНорм.Удалить();
Значение не представляет агрегатный объект (Удалить)


Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Удаление истории
« Ответ #7: 01 Фев 2012, 10:12 »
а если СпрН.ИндЗимняяНорма.ПолучитьЗначение('31.12.2011').Удалить();
то ошибка
 Поле агрегатного объекта не обнаружено (ПолучитьЗначение)

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: Удаление истории
« Ответ #8: 01 Фев 2012, 10:36 »
Пишу по памяти
	Периодический = СоздатьОбъект("Периодический");

СпрН = СоздатьОбъект("Справочник.Нас_Население");
СпрН.ВыбратьЭлементы();
Пока СпрН.ПолучитьЭлемент() > 0 Цикл
Если спрН.ЭтоГруппа() = 0 тогда
Потребитель = СпрН.ТекущийЭлемент();
Если Потребитель.Дом.ТипДома =  Перечисление.ТипДома.Многоэтажный Тогда
Периодический.ИспользоватьОбъект("ИндЗимняяНорма",СпрН.ТекущийЭлемент());
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение()=1 Цикл
Если Периодический.ДатаЗнач = '31.12.2011' Тогда
Периодический.Удалить();
Продолжить;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецЦикла; 
Кнопочка Спасибо - слева!

Оффлайн Dima09

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-01
  • Сайт: 
  • Профессия: Программист 7.7
Re: Удаление истории
« Ответ #9: 01 Фев 2012, 11:18 »
Спасибо!!!!!! Вопрос решен


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 587
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal