Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите по управляемым формам  (Прочитано 4961 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Подскажите по управляемым формам, в документе сделала кнопку, прописала действие, но...в модуле формы...НаКлиенте перед процедурой, загружая в простом приложении работает, в управляемом ошибку выдает - могу предоставить текст процедуры
Тазовод)


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Текст ошибки и текст процедуры

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура СформироватьСчет(Команда)
ЗапросСписокОрг = Новый Запрос;
   ЗапросСписокОрг.Текст =
   "ВЫБРАТЬ
   |   МаршрутныйЛистАвтомобиляТабЧасть.ЛистКомплектации.ДокументОснование.Организация КАК Организация,
   |   МаршрутныйЛистАвтомобиляТабЧасть.Объем
   |ИЗ
   |   Документ.МаршрутныйЛистАвтомобиля.ТабЧасть КАК МаршрутныйЛистАвтомобиляТабЧасть
   |ГДЕ
   |   МаршрутныйЛистАвтомобиляТабЧасть.Ссылка = &МаршрутныйЛист";
   ЗапросСписокОрг.УстановитьПараметр("МаршрутныйЛист",Объект.Ссылка);
   СписокОрг = ЗапросСписокОрг.Выполнить().Выгрузить();
   СписокОрг.Свернуть("Организация","Объем");
   Для каждого СтрокаОрг из СписокОрг Цикл
      //создаем документ счет за транспортное обслуживание
      ДокСчетЗаТрОбсл= Документы.СчетЗаТранспортноеОбслуживание.ПолучитьФормуНовогоДокумента();
      ДокСчетЗаТрОбсл.Объект.Фирма = СтрокаОрг.Организация;
      ДокСчетЗаТрОбсл.Объект.Водитель = Объект.Перевозчик;
      ДокСчетЗаТрОбсл.Объект.Куда = Объект.Направление;
      ДокСчетЗаТрОбсл.Объект.МаршрутныйЛист = Объект.Ссылка;
      ОбъемДокумента = Объект.ТабЧасть.Итог("Объем");
      СуммаДокумента = Объект.ТранспортныеРасходы*СтрокаОрг.Объем/ОбъемДокумента;
      ДокСчетЗаТрОбсл.Объект.Сумма = СуммаДокумента;
      ДокСчетЗаТрОбсл.КлючУникальности = Строка(СтрокаОрг.Организация)+" "+Строка(Объект.Перевозчик);
      ДокСчетЗаТрОбсл.Открыть();
      //проверить счет только перевозчику или экспедитору тоже...
      Если НЕ Объект.Экспедитор = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда
         ДокСчетЗаТрОбсл= Документы.СчетЗаТранспортноеОбслуживание.ПолучитьФормуНовогоДокумента();
         ДокСчетЗаТрОбсл.Объект.Фирма = СтрокаОрг.Организация;
         ДокСчетЗаТрОбсл.Объект.Водитель = Объект.Экспедитор;
         ДокСчетЗаТрОбсл.Объект.Куда = Объект.Направление;
         ДокСчетЗаТрОбсл.Объект.МаршрутныйЛист = Объект.Ссылка;
         ОбъемДокумента = Объект.ТабЧасть.Итог("Объем");
         СуммаДокумента = Объект.ТранспортныеРасходыЭкспедитора*СтрокаОрг.Объем/ОбъемДокумента;
         ДокСчетЗаТрОбсл.Объект.Сумма = СуммаДокумента;
         ДокСчетЗаТрОбсл.КлючУникальности = Строка(СтрокаОрг.Организация)+" "+Строка(Объект.Экспедитор);
         ДокСчетЗаТрОбсл.Открыть();
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры
 
Ошибка при открытии формы в управляемом интерфейсе.
Тазовод)

Оффлайн aprol

  • *
  • Сообщений: 35
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-28
  • Сайт: 
  • Профессия: Консультант 1С
На клиенте запросы писать нельзя, создавай отдельно процедуру на сервере, выполняй там запрос и обрабатывай его.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Это я понимаю, я пробовала вынести запрос, потом:
ДокСчетЗаТрОбсл= Документы.СчетЗаТранспортноеОбслуживание.ПолучитьФормуНовогоДокумента(); - в отдельную процедуру
Справочники.ФизическиеЛица.ПустаяСсылка()   - в отдельную процедуру и что то совсем получается каша, как быть?
Тазовод)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Форму документа по другому получают в управляемых формах. Там вроде такой метод ПолучитьФорму().
Пустую ссылку скорей всего тоже придется на сервер получать, посмотрите в СП где выполняется метод ПустаяСсылка.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вынесите на сервер только запрос.
Работу с формами можно оставить на клиенте...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Выносила, результатом запроса является таблица значений, которую потом передать в процедуру (на клиенте) не получается
Тазовод)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пока тоже мало опыта в УпрФ...
Но как-то решал такую задачу...
ТаблицаЗначений действительно не передается с сервера на клиент.
А вот МАССИВ СТРУКТУР - отлично передается...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
ТаблицаЗначений действительно не передается с сервера на клиент.
А вот МАССИВ СТРУКТУР - отлично передается...
Спасибо по пробую....
Тазовод)


Теги:
 

Не формируется штрих код.Пишет ошибочный штрих код в тексте кода и подставляет стандартный штрих код.Подскажите как сформировать штрих код состоящий из букв и цифр?

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 679
Последний ответ 31 Янв 2017, 14:02
от Kironten
Подскажите в документе "РасходнаяНакладная"

Автор n24nРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2285
Последний ответ 05 Мар 2011, 20:55
от n24n
Подскажите как реализовать "планинг"?

Автор cannabis_86Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2151
Последний ответ 20 Июн 2011, 10:29
от cska-fanat-kz
Добрый вечер! Прошу помочь, кто знает, подскажите пож. В счете не выводит грузоотправителя и грузополучаетля. Куда их внести ? Как сделать что бы выводило ? У меня 1с 8.3 редакция 11.1 управление торговлей Спасибо!

Автор Farid GasimliРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1973
Последний ответ 07 Фев 2016, 14:34
от pavl_vs
1 страница - портрет, 2 страница - ландшафт Подскажите как сделать?

Автор YaposhaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4571
Последний ответ 05 Апр 2012, 11:37
от Yaposha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal