Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 20:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Связка справочника Пользователи и ПользователиИнформационнойБазы  (Прочитано 6766 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн onegreyonewhite

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Пытаюсь создать 2 справочника: Пользователи и Сотрудники.
Проблем сразу несколько:
1. Как сделать проверку в справочниках Пользователи и Сотрудники
Процедура ПриВыбореЭлемента()
Если ТекущийПользователь = Администратор Тогда
       Форма = ПолучитьФорму(форма для сисадмина);
       Форма.Открыть();
ИначеЕсли ПользовательИзЭтогоСправочника = ТекущийПользователь Тогда
       Форма = ПолучитьФорму(форма для пользователя, редактируемая);
       Форма.Открыть();
Иначе
       Форма = ПолучитьФорму(Форма для пользователя, только просмотр);
       Форма.Открыть();
КонецЕсли;

Притом я хочу организовать такую проверку в обоих справочниках ибо защита от пакостников нужна очень сильно.

2. Как сделать проверку (тут надо проверить на наличие ошибок)
Процедура СоздатьПользователя(Имя, ПолноеИмя, Пароль, Должность) Экспорт
//Должность является объектом перечисления который по названию сопоставим с Ролями.
Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени(Имя);
РольПользователя = Метаданные.Роли.Найти(Должность);
Если Пользователь = Неопределено Тогда
      Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
      Пользователь.Имя = Имя;
      Пользователь.ПолноеИмя = ПолноеИмя;
      Пользователь.Пароль = Пароль;
      Пользователь.Роли.Добавить(РольПользователя);
      Пользователь.Записать();
ИначеЕсли Пользователь.Имя = Имя Тогда
      Пользователь.Пароль = Пароль;
      Если Пользователь.Роли.Содержит(РольПользователя) Тогда
            Пользователь.Записать();
      Иначе
            Пользователь.Роли.Очистить();
            Пользователь.Роли.Добавить(РольПользователя);
            Пользователь.Записать();
      КонецЕсли;
КонецЕсли;
КонецПроцедуры

И собственно говоря проблема в чём... Мне база кажет, что Имя не является элементом объектного типа (Я строку с именем передаю).


Оффлайн onegreyonewhite

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Да, и ещё... После выполнения процедуры ПриВыбореЭлемента() из первого листинга открывается (если вообще открывается) только последняя форма, и основная которая указана основной для справочника. Whatta fack?! :(

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Насчет первого листинга...
1. Мы методом ясновидения должны догадаться, какие значения "сидят" в переменных "Администратор" и "ПользовательИзЭтогоСправочника"?
2. "форма для сисадмина", "Форма для пользователя" - насторожили пробелы....
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн onegreyonewhite

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Ученик 1С
Насчет первого листинга...
1. Мы методом ясновидения должны догадаться, какие значения "сидят" в переменных "Администратор" и "ПользовательИзЭтогоСправочника"?
2. "форма для сисадмина", "Форма для пользователя" - насторожили пробелы....

1. Вот я и думаю, что надо сахреначить в эти переменные :) чтоб всё это работало ;)
2. Это образные названия.


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6499
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4200
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 632
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2038
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal