Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Общий журнал документов  (Прочитано 4481 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sign-stone

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-03-17
  • Сайт: 
В 1С 7.7 "Бухгалтерия для бюджетных учреждений" (конфигурация Камин:расчет зарплаты) в Общем журнале документов есть такая задумка - добавить кнопку печати и в обработчике печати  осуществить печать документов за выбранный период или по отбору по подразделениям.
Надо программно осуществить:
1) устанавливаем отбор по подразделению (поле ввода: рд_Сотрудник)
2) в табличной части журнала появляется список документов различного вида
3) необходимо этот список распечатать (печатная форма имеет колонки: дата-номер-сумма-вид документа-описание документа)
_____________________________________________________________________________________________________________

Я не могу из табличной части документа извлечь реквизит Подразделение!

// Печать отбор по подразделению
   Если рд_Сотрудник.Выбран() = 1 Тогда
      Если (рд_Сотрудник.Вид() = "Подразделения") Тогда
                  
         Док = СоздатьОбъект("Документ");
         Док.ИспользоватьЖурнал("Общий");
         Таб = СоздатьОбъект("Таблица");
         Таб.ИсходнаяТаблица("Печать");
         Таб.ВывестиСекцию("Шапка");
         Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
         Док.ВыбратьДокументы(НачалоИнтервала(),КонецИнтервала());         
         
         Пока Док.ПолучитьДокумент() = 1 Цикл      
            // ???????не могу из табличной части документа извлечь реквизит Подразделение????????
            //   Если ?????? Тогда   
            //   Таб.ВывестиСекцию("Строка");         
            //КонецЕсли;
         КонецЦикла;          
         
         Таб.ВывестиСекцию("Подвал");   
         Таб.ТолькоПросмотр(1);
         Таб.Показать("Печать общий журнал","");      
      КонецЕсли;
   КонецЕсли;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal