Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 окт 2021, 17:05

Общий журнал документов

Автор sign-stone, 17 апр 2009, 05:32

0 Пользователей и 1 гость просматривают эту тему.

sign-stone

В 1С 7.7 "Бухгалтерия для бюджетных учреждений" (конфигурация Камин:расчет зарплаты) в Общем журнале документов есть такая задумка - добавить кнопку печати и в обработчике печати  осуществить печать документов за выбранный период или по отбору по подразделениям.
Надо программно осуществить:
1) устанавливаем отбор по подразделению (поле ввода: рд_Сотрудник)
2) в табличной части журнала появляется список документов различного вида
3) необходимо этот список распечатать (печатная форма имеет колонки: дата-номер-сумма-вид документа-описание документа)
_____________________________________________________________________________________________________________

Я не могу из табличной части документа извлечь реквизит Подразделение!

// Печать отбор по подразделению
   Если рд_Сотрудник.Выбран() = 1 Тогда
      Если (рд_Сотрудник.Вид() = "Подразделения") Тогда
                  
         Док = СоздатьОбъект("Документ");
         Док.ИспользоватьЖурнал("Общий");
         Таб = СоздатьОбъект("Таблица");
         Таб.ИсходнаяТаблица("Печать");
         Таб.ВывестиСекцию("Шапка");
         Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
         Док.ВыбратьДокументы(НачалоИнтервала(),КонецИнтервала());         
         
         Пока Док.ПолучитьДокумент() = 1 Цикл      
            // ???????не могу из табличной части документа извлечь реквизит Подразделение????????
            //   Если ?????? Тогда   
            //   Таб.ВывестиСекцию("Строка");         
            //КонецЕсли;
         КонецЦикла;          
         
         Таб.ВывестиСекцию("Подвал");   
         Таб.ТолькоПросмотр(1);
         Таб.Показать("Печать общий журнал","");      
      КонецЕсли;
   КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск