Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июн 2018, 11:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с кодом отчета  (Прочитано 2254 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Возникла необходимость в создании нового внешнего отчета..у меня получилось составить диалоговую форму в которой буду вибирать дату начала и дату конца периода и выбор экспедитора..ну так вот..необходимо по выбранному экспедитору составить процедуру при которой будут выводится сумма реализации. В общем должна происходить проверка по маршрутным листам данного экспедитора..у которых в трабличной части в Реализации будет цифра 1 колонке НФ (НалФакт) она находится в шапке Реализации..конфигурация 1с 7.7 торговля и склад..


Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
вот немного набросала..может подскажет кто...правильно ли я делаю...
Процедура Сформировать()
   ОбщСумма=0;
   Таб=СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
    Док=СоздатьОбъект("Документ.МаршрутныйЛиста");
   Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Таб.ВывестиСекцию("Заголовок");
    Таб.ВывестиСекцию("Шапка");
   Пока Док.ПолучитьДокумент()=1 Цикл
      Если Док.Экспедитор=Экспедитор Тогда 

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
До этого места все почти правильно. Но конструктором запроса будет быстрее
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
До этого места все почти правильно. Но конструктором запроса будет быстрее


Конструктором я не умею.. а вот в коде не совсем еще понимаю..по обрывкам в интернете ищу...и собираю свой код..только пока в ступоре..не знаю как дальше...

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Сумма = Док.Итог("Сумма"); ?????????????
ОбщСумма = ОбщСумма+сумма;
Таб.ВывестиСекцию("строка");
конецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
Таб.Показать();
Кнопочка Спасибо - слева!

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Сумма = Док.Итог("Сумма"); ?????????????
ОбщСумма = ОбщСумма+сумма;
Таб.ВывестиСекцию("строка");
конецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Итого");
Таб.Показать();
Сергей, стисняюсь спросить..что означают знаки вопросов?

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо Сергей за помощь! Вот мой окончательный вариант..я убрала сортировку по Экспедиторам..
Процедура Сформировать()
   ОбщСумма=0;
   Таб=СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
    Док=СоздатьОбъект("Документ.МаршрутныйЛист");
   Док.ВыбратьДокументы(ДатаНачала,ДатаКонца);
    Таб.ВывестиСекцию("Заголовок");
   Таб.ВывестиСекцию("Шапка");
   Пока Док.ПолучитьДокумент()=1 Цикл
   
      
         Док.ВыбратьСтроки();
         Пока Док.ПолучитьСтроку()=1 Цикл
            Если Док.ДокОтгрузки.Нф=1 Тогда
               Сумма = Док.ДокОтгрузки.Итог("Сумма");
               ОбщСумма = ОбщСумма+сумма;   
               Эксп=Док.ЭкспедиторСТР;
               Таб.ВывестиСекцию("строка");
            КонецЕСли;
         КонецЦикла;

   
   КонецЦикла;
   Таб.ВывестиСекцию("Итого");   
   ТАб.ТолькоПросмотр(1);
   Таб.Показать();
   

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
125 Сообщений
AIFrame AIFrame
125 Сообщений
alexandr_ll
61 Сообщений
pavl_vs
50 Сообщений
alex0402
30 Сообщений
buketov.av buketov.av
27 Сообщений
ilyay ilyay
25 Сообщений
magnifico61
21 Сообщений
wise wise
20 Сообщений
trialex3
15 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal