Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 08:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ошибка при загрузке информационной базы  (Прочитано 5079 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн taniafan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-24
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, кто может сталкивался: при загрузке инф. базы и попытке перейти в базу, выдает ошибку: "Поле объекта не обнаружено (Идентификатор Клиента).
Подробно: {ОбщийМодуль.МенеджерОборудованияСервер(180)}: Поле объекта не обнаружено (ИдентификаторКлиента)
      СписокРМ = НайтиРабочиеМестаПоИД(ВРег(СистемнаяИнформация.ИдентификаторКлиента));

В конфигураторе:
Процедура УстановитьПараметрыСеансаПодключаемогоОборудования(ИмяПараметра, УстановленныеПараметры) Экспорт

   Если ИмяПараметра = "РабочееМестоКлиента" Тогда
      
      //Если с идентификатором клиента текущего сеанса связано одно рабочее место,
      // то его сразу и запишем в параметры сеанса
      ТекущееРМ           = Справочники.РабочиеМеста.ПустаяСсылка();
      СистемнаяИнформация = Новый СистемнаяИнформация();

      СписокРМ = НайтиРабочиеМестаПоИД(ВРег(СистемнаяИнформация.ИдентификаторКлиента));
      Если СписокРМ.Количество() = 0 Тогда
         
         // Будет создано с клиента.
         
      ИначеЕсли СписокРМ.Количество() = 1 Тогда
         
         ТекущееРМ = СписокРМ[0];
         
      ИначеЕсли СписокРМ.Количество() > 1 Тогда
         
         // Будет выбрано на клиенте.
         
      КонецЕсли;
      
      УстановитьРабочееМестоКлиента(ТекущееРМ);
      
      УстановленныеПараметры.Вставить("РабочееМестоКлиента");
      
   КонецЕсли;
   
КонецПроцедуры



Как это можно исправить?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Попробуй chdbfl.exe если база файловая
Если SQL - тогда попробуй просто удалить базу из списка баз и заново добавить.
Если это случилось после обновления - значит что то снесли!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн taniafan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-24
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, зайти удалось с помощью chdbfl.exe.
Теперь другая проблема: при формировании любого отчета выдает:

Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(110, 2)}: Ожидается выражение "СПИСОК"
<<?>>ВЫБОР

Как исправить?


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5091
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6812
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4868
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10327
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Синтаксическая ошибка "ИЗ"

Автор kulkriseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5140
Последний ответ 26 Янв 2014, 19:33
от kulkrise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
32 Сообщений

* Кто онлайн

  • Точка Гостей: 414
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal