Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 15:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение в табличной части ДокументСсылка  (Прочитано 1657 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serq82

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-25
  • Сайт: 
  • Профессия: Бухгалтер
Уважаемые Гуру помогите новичку,плизззззззззз.
В УТ11 создал документ ЗаданиеНаПроизводство, в документе ЗаказКлиента добавил команду ЗаданиеНаПроизводство, по заказу начальство нужно было чтобы документы формировались по ВидНоменклатуры, вот код правда он не полностью доработан
&НаКлиенте
функция ТаблСтруктура()
    стр = Новый Структура;
    стр.Вставить("объект",объект);
     Возврат стр;
КонецФункции

//возвражает таблицу с номенклатурой по родителю
&НаСервере
функция СпрвернутьВидПономенклатуре(с)
 Возврат Справочники.Номенклатура.НайтиПоНаименованию(Строка(с)).ВидНоменклатуры.Наименование;             
КонецФункции


//Создание Документа только под одному виду номеклатуры
&НаСервере
Процедура СоздатьДокументЗаданиеНаПроизводство(стр,ВидНоменклатуры)
 Если ЗначениеЗаполнено(ВидНоменклатуры) тогда     
 ЗаданиеНаПроизводство             = Документы.ЗаданиеНаПроизводство.СоздатьДокумент();
 ЗаданиеНаПроизводство.Дата        = стр.Объект.Дата;
 ЗаданиеНаПроизводство.Контрагент  = стр.Объект.Контрагент;
 ЗаданиеНаПроизводство.Организация = стр.Объект.Организация;
 ЗаданиеНаПроизводство.Склад       = стр.Объект.Склад;
 
 Колво = стр.объект.Товары.Количество();
 
 Для н=0 по  (Колво-1) Цикл
     Если Строка(стр.объект.товары[н].Номенклатура.ВидНоменклатуры) = ВидНоменклатуры   Тогда
         Товары = ЗаданиеНаПроизводство.Товары.Добавить();
         Товары.Количество = стр.объект.товары[н].Количество;
         Товары.Номенклатура = стр.объект.товары[н].Номенклатура;
        Товары.Длина = стр.объект.товары[н].Длина;//.Наименование;
    КонецЕсли;       
 КонецЦикла;
 
 Попытка
 ЗаданиеНаПроизводство.Записать();
Исключение
       Сообщить("неудача млять ");
 КонецПопытки;
 КонецЕсли;
КонецПроцедуры

&НаСервере
функция СтрукВидыНомеклатуры(стр)
КС = Новый КвалификаторыСтроки(100);         
Массив = новый Массив;
Массив.Добавить(Тип("Строка"));
ОписаниеТиповС = Новый ОписаниеТипов(Массив,,КС);
Массив.Очистить();
ТЗ = новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("Номеклатура",ОписаниеТиповС,"Номеклатура");
ТЗ.Колонки.Добавить("ВидНомеклатуры",ОписаниеТиповС,"ВидНомеклатуры");

 Колво = стр.Объект.Товары.Количество();


Для н=0 по  (Колво-1) Цикл
       с                  = тЗ.Добавить();
       Номеклатура          = стр.объект.Товары[н].Номенклатура;
        ВидНомеклатуры       = СпрвернутьВидПономенклатуре(Строка(стр.объект.Товары[н].Номенклатура));
       С.Номеклатура         = Номеклатура;
       С.ВидНомеклатуры   = ВидНомеклатуры;
КонецЦикла;
        запрос = новый запрос();
         МенеджерВТ=Новый МенеджерВременныхТаблиц;
          Запрос.МенеджерВременныхТаблиц = МенеджерВТ;
         
         текст ="ВЫБРАТЬ РАЗЛИЧНЫЕ
                |     ВидыНомеклатуры.ВидНомеклатуры как  Номеклатуры
                |ПОМЕСТИТЬ ВидыНомеклатуры
                |ИЗ
                |     &ВидыНомеклатуры КАК ВидыНомеклатуры";
                 
                   
         
          Запрос.УстановитьПараметр("ВидыНомеклатуры",ТЗ);
          Запрос.Текст = текст;
          Запрос.Выполнить();
         
          Запрос.Текст = "ВЫБРАТЬ
         |     ВидыНомеклатуры.Номеклатуры как  Номеклатура
         |ИЗ
         |     ВидыНомеклатуры КАК ВидыНомеклатуры";
       ТЗН = Запрос.Выполнить().Выгрузить();
       
        массив= Новый массив;
       для н=0 по (ТЗН.Количество()-1) цикл
            массив.Вставить(н,ТЗН[н].Номеклатура);       
        КонецЦикла;       
       
        возврат массив;         
КонецФункции

&НаКлиенте
Процедура ЗаданиеНаПроизводство(Команда)
     стр = Новый Структура;
    стр.Вставить("объект",объект);
     ВРазные = СтрукВидыНомеклатуры(стр);                         
     
     для н=0 по  (ВРазные.количество()-1) цикл     
                   
          СоздатьДокументЗаданиеНаПроизводство(ТаблСтруктура(),Строка(ВРазные[н]));
         
     КонецЦикла;
     
КонецПроцедуры
документы создаются все гуд
теперь подскажите как мне заполнить в табличной части?


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3592
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1935
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3048
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Заполнение поля справочника из подчиненного справочника

Автор Space_minusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1263
Последний ответ 19 Авг 2016, 05:01
от Space_minus
Заполнение формы на основании другой формы

Автор Саша АлдаевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 343
Последний ответ 11 Июл 2017, 00:11
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 881
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal