Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с присвоением  (Прочитано 1647 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Выдаёт ошибку при заходе на  ВыборкаСправочника.Остаток.Значение = СуммОст;


   ~метка:
  Ост = 0;
  СуммОст = 0;
   Сообщить("Заход");

  ВыборкаСправочника = Справочники.Деньги.Выбрать();

  Пока ВыборкаСправочника.Следующий() Цикл
    
        ВыборкаСправочника.Остаток.Значение = СуммОст; // как свойству присвоить эту строку(?
    
     Если ВыборкаСправочника.ЭтоГруппа Тогда
       
        Если Ост = 1 Тогда
           Перейти ~метка;
           Иначе Ост = 1;
        КонецЕсли;
       
     Иначе
        СуммОст = СуммОст + ВыборкаСправочника.Остаток;

       
     КонецЕсли;
 
  КонецЦикла;
    


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Не надо использовать безусловный оператор! Он уже устарел. Попытайтесь обойтись без него.

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Сделайте лучше простым запросом приблизительно так:
ВЫБРАТЬ
БюджетВыплат.ЭтоГруппа КАК ЭтоГруппа,
СУММА(БюджетВыплат.Бюджет) КАК Бюджет
ИЗ
Справочник.БюджетВыплат КАК БюджетВыплат
ГДЕ
БюджетВыплат.ЭтоГруппа = ЛОЖЬ

СГРУППИРОВАТЬ ПО
БюджетВыплат.ЭтоГруппа

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Замените слово БюджетВыплат на Деньги, а слово Бюджет на Остаток

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
 ~метка:
  Ост = 0;
  СуммОст = 0;
   Сообщить("Заход");

  ВыборкаСправочника = Справочники.Деньги.Выбрать();

  Пока ВыборкаСправочника.Следующий() Цикл
    ОбъектЭлемента = ВыборкаСправочника.Ссылка.ПолучитьОбъект();
        ОбъектЭлемента.Остаток = СуммОст; // ВОТ ТАК
ОбъектЭлемента.Записать();
   
     Если ВыборкаСправочника.ЭтоГруппа Тогда
       
        Если Ост = 1 Тогда
           Перейти ~метка;
           Иначе Ост = 1;
        КонецЕсли;
       
     Иначе
        СуммОст = СуммОст + ВыборкаСправочника.Остаток;

       
     КонецЕсли;
 
  КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Только я думаю эта хрень работать врядли будет.
Выкинет с ошибкой на Группе
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1175
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4689
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2418
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3319
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3572
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal