Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обмен заказами с сайтом...  (Прочитано 10790 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Друзья, нужна Ваша помощь...
Конфигурация: 1С УПП, 8.2 (Ликероводочный и винный завод)

Так как 1С программист занят решением задач с бухгалтерией, приходится возиться с 1С мне, а я прямо скажу в этом вопросе Дуб-дубом...
В общем ситуация такая. При выгрузке ("записывать", "Только изменения") с сайта заказов в 1С, все превосходно пишется. Однако при проведении заказа и последующей выгрузке изменений документ имеющий статус ПРОВЕДЕН, перезаписывается и становится не проведенным в 1С-ке.... А если помечаешь заказ на удаление, то такой заказ не перезаписывается...?!

Вопрос такой, что нужно дописать в обмене, чтобы ЕСЛИ Проведен ТО не перезаписывать...
Если я правильно понимаю, то за обмен с сайтом отвечает файл во вложении.. Поправьте меня если я не прав!!!


Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Пробовал сделать так...
Функция СоздатьОбновитьДокументы(ДеревоДокументов, СтруктураСтатистики, МассивДокументовДляПроведения, МассивЗагруженныхДокументов)
   
   Успешно = Истина;
   
   Для Каждого Док Из ДеревоДокументов.Строки Цикл
      
      // если на документ есть ссылки, то он вообще пропускается и не загружается
      Если Док.ЕстьСсылкиНаРанееЗагруженныйДокумент Тогда
         СтруктураСтатистики.Пропущено = СтруктураСтатистики.Пропущено + 1;
         Продолжить;
      КонецЕсли;      
      
      //добавил, но не работает...
      Если Док.ДокументОбъект.Проведен = Истина Тогда
            Сообщить("Статус проведен");
         СтруктураСтатистики.Пропущено = СтруктураСтатистики.Пропущено + 1;
         Продолжить;
      КонецЕсли;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А что такое ДокументОбъект? - тип какой? Как он попал в ДеревоДокументов?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
ДокументОбъект... как я понимаю это часть XML файла, которая несет в себе информацию, в данном конкретном случае "ПРОВЕДЕН" = true или falce...
А в общем я в первом посте дал ссылку на весь файл целиком.
Думаю это стандартная конфигурация обмена с сайтом для УПП! не для УТ!
Я там ни чего не правил, мне сказали все из коробки.. .но не работает ((

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Я думаю они в XML всегда "Проведен = False"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Я думаю они в XML всегда "Проведен = False"
Нет не всегда. Если документ проведен в 1С, то он сразу становится TRUE, даже при том, что у документа нет даты отгрузки или даты оплаты..
Это хорошо видно из XML во вложении ))

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот эти строки кода говорят о том что он всегда не проведен вне зависимости от того что в твое XML
	Если ИмяЭлемента = "Документ" Тогда

НовыйДокумент    = Документы.ЗаказПокупателя.СоздатьДокумент();
НовыйДокумент.УчитыватьНДС    = Истина;
НовыйДокумент.СуммаВключаетНДС = Истина;
НовСтрокаДерева    = ДеревоДокументов.Строки.Добавить();
НовСтрокаДерева.ДокументОбъект = НовыйДокумент;
НовСтрокаДерева.СтавкаНДС    = Перечисления.СтавкиНДС.БезНДС;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот стоки кода где перезаписываются найденные документы:
Для Каждого СтрокаДД Из ДеревоДокументов.Строки Цикл

Если НЕ ЗначениеЗаполнено(СтрокаДД.РанееЗагруженныйДокументСсылка) Тогда
Продолжить;
КонецЕсли;

ДокументОбъект = СтрокаДД.РанееЗагруженныйДокументСсылка.ПолучитьОбъект();

Если НЕ СтрокаДД.ЕстьСсылкиНаРанееЗагруженныйДокумент Тогда

ЗаполнитьЗначенияСвойств(ДокументОбъект, СтрокаДД.ДокументОбъект, , "Номер");
ДокументОбъект.Товары.Очистить();
ДокументОбъект.Услуги.Очистить();

КонецЕсли;

СтрокаДД.ДокументОбъект = ДокументОбъект;

КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Тебе просто из дерева нужно вычищать совсем те документы которые уже найдены в БД
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Kintim

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2012-01-19
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за ответы..
Буду пытаться понять что да как...


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 236
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal