Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 11:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как свойство объекта сравнить со строкой?  (Прочитано 1715 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Процедура ПриЗаписи(Отказ)
   // Вставить содержимое обработчика.

        перем ПереведённаяСумма;
   
   КошелНаимен = ЭлементыФормы.Кошелек.Значение.Наименование;
   СправочникКошел = Справочники.Деньги.НайтиПоНаименованию(КошелНаимен);
         ОбъектСпр = СправочникКошел.ПолучитьОбъект();
      

       Если ОбъектСпр.Валюта = ЭлементыФормы.Валюта.Значение Тогда   
      ОбъектСпр.Остаток = ОбъектСпр.Остаток + ЭлементыФормы.ПолеСумма.Значение;//Тут всё сравнивается замечательно
       КонецЕсли;

      
      
      
      Сообщить(ОбъектСпр.Валюта); // Сообщает: Руб.
                     
      вал = "Руб.";

           Если ОбъектСпр.Валюта = вал  Тогда
      Сообщить("!!!!!!!"); // Тут всегда ложь  :wacko:
      КонецЕсли;

КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
вал = Справочники.Валюты.НайтиПоНаименованию("Руб");
Если ОбъектСпр.Валюта = вал  Тогда
      Сообщить("Ура у меня получилось ссылку сравнить!!!! Я гений!!!!"); 
      КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
вал = Справочники.Валюты.НайтиПоНаименованию("Руб");
Если ОбъектСпр.Валюта = вал  Тогда
      Сообщить("Ура у меня получилось ссылку сравнить!!!! Я гений!!!!"); 
      КонецЕсли;

Пытался так сделать через справочники не выходило. Но понял суть. Сделал иначе :  вал = Перечисления.Валюта.Руб;
Спасибо.


Теги:
 

{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2410
Последний ответ 09 Дек 2015, 19:33
от Oks
Метод объекта не обнаружен. Но метод есть.

Автор ВитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 13367
Последний ответ 10 Фев 2015, 21:54
от vitasw
Ошибка "Поле объекта не обнаружено"

Автор KSV67Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4622
Последний ответ 29 Май 2014, 22:11
от KSV67
Общий реквизит или одинаковый реквизит для каждого объекта

Автор Соловьева Ольга_ИнтерсРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 971
Последний ответ 15 Июн 2015, 14:23
от cska-fanat-kz
Проблема "Метод объекта не обнаружен"

Автор aleks159Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2501
Последний ответ 13 Дек 2016, 16:34
от aleks159

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 307
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal