Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 11:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу записать в ячеку значения  (Прочитано 2519 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Помогите. Как можно присвоить каждой строке ячейки(Остаток) значение 90.
У меня выдает ошибку "Поле объекта не доступно для записи (Остаток)" хотя если убрать за комментированную  функцию сообщить то компилятор выводит все значения ячейки остатка. Справочник иерархический, даже выводятся из всех групп значения остатка, а поменять аналогично значения нельзя, почему?((( 

Процедура ПолеДатаПриИзменении(Элемент)
// Вставить содержимое обработчика.

ВыборкаСправочника = Справочники.Деньги.Выбрать();

Пока ВыборкаСправочника.Следующий() Цикл


ВыборкаСправочника.Остаток = 90;


//Сообщить(ВыборкаСправочника.Остаток);

КонецЦикла;


КонецПроцедуры



Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПолеДатаПриИзменении(Элемент)
    // Вставить содержимое обработчика.
    
ВыборкаСправочника = Справочники.Деньги.Выбрать();

Пока ВыборкаСправочника.Следующий() Цикл
    ОбъектВыб = ВыборкаСправочника.Ссылка.ПолучитьОбъект();

    ОбъектВыб.Остаток = 90;


//Сообщить(ОбъектВыб.Остаток);

КонецЦикла;

    
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Процедура ПолеДатаПриИзменении(Элемент)
    // Вставить содержимое обработчика.
   
ВыборкаСправочника = Справочники.Деньги.Выбрать();

Пока ВыборкаСправочника.Следующий() Цикл
    ОбъектВыб = ВыборкаСправочника.Ссылка.ПолучитьОбъект();

    ОбъектВыб.Остаток = 90;


//Сообщить(ОбъектВыб.Остаток);

КонецЦикла;

   
КонецПроцедуры


сейчас пишет:


{Справочник.Деньги.Форма.ФормаСписка(9)}: Ошибка при установке значения атрибута контекста (Остаток): Реквизит недоступен для группы
    ОбъектВыб.Остаток = 90;
по причине:
Реквизит недоступен для группы

Оффлайн AxOn

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-04
  • Сайт: 
Всё разобрался Dethmontt спасибо огромное


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 275
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3906
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 977
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 13476
Последний ответ 04 Май 2017, 10:48
от ospov11789
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 840
Последний ответ 17 Авг 2016, 11:25
от Караул

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 939
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal