Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 18:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка  (Прочитано 3844 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SCORP26

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-14
  • Сайт: 
  • Профессия: Бухгалтер
Добрый вечер!
Может кто-то помочь?
Нужно доделать обработку заполнить документ инвентаризация товаров на складе по группе номенклатуры БП 2.0 1с 8.2
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПоле) Экспорт;
   
   Форма = Справочники.Номенклатура.ПолучитьФормуВыбораГруппы();   
   Группа = Форма.ОткрытьМодально();
   Если Группа = Неопределено Тогда
      Возврат;
   КонецЕсли;
   
   Объект[ИмяТабличнойЧасти].Очистить();
   
   Выборка = Справочники.Номенклатура.Выбрать(Группа);
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЭтоГруппа Тогда
         Продолжить;
      КонецЕсли;

      СтрокаТабличнойЧасти = Объект[ИмяТабличнойЧасти].Добавить();
      СтрокаТабличнойЧасти.Номенклатура = Выборка.Ссылка;
   КонецЦикла;

КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А где вопрос то?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн SCORP26

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-14
  • Сайт: 
  • Профессия: Бухгалтер
Добрый вечер!
Может кто-то помочь?
Нужно доделать обработку заполнить документ инвентаризация товаров на складе по группе номенклатуры БП 2.0 1с 8.2
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПоле) Экспорт;
   
   Форма = Справочники.Номенклатура.ПолучитьФормуВыбораГруппы();   
   Группа = Форма.ОткрытьМодально();
   Если Группа = Неопределено Тогда
      Возврат;
   КонецЕсли;
   
   Объект[ИмяТабличнойЧасти].Очистить();
   
   Выборка = Справочники.Номенклатура.Выбрать(Группа);
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЭтоГруппа Тогда
         Продолжить;
      КонецЕсли;

      СтрокаТабличнойЧасти = Объект[ИмяТабличнойЧасти].Добавить();
      СтрокаТабличнойЧасти.Номенклатура = Выборка.Ссылка;
   КонецЦикла;

КонецПроцедуры

БП 2.0 1с 8.2 документ инвентаризация товаров на складах, есть кнопка заполнить по остаткам на складе. Нужна обработка заполнить остатками по выбраной группе номенклатуры на складе.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Вопрос спрашивают. Или сделать обработку за тебя?

Оффлайн donyab

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-19
  • Сайт: 
  • Профессия: Программист 8.1
Когда вставляешь код обрамляй его тегом [code ] (ток без пробела))

Оффлайн SCORP26

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-10-14
  • Сайт: 
  • Профессия: Бухгалтер
Вопрос спрашивают. Или сделать обработку за тебя?
Если не трудно, напишите. Или подскажите, как написать.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 337
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal