Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 11:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите. Корректировка начальных сальдо при переносе ис 7.7 в 8.2 через OLE  (Прочитано 3227 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EnigMan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-17
  • Сайт: 
  • Профессия: Бухгалтер
Данные из 7.7 переносились в спешке, теперь необходимо откорректировать сведения по стоимости ОС в 8.2
написал внешнюю обработку:
Процедура КнопкаЗапольнитьОС(кнопка)
//Подключаем семерку
БДБух = Новый COMОбъект("V1CEnterprise.Application");
рез=БДБух.initialize(БДБух.RMAccount,"/D"+СокрЛП(АдресБазы),"NO_SPLASH_SHOW");
Если Рез=0 тогда
Сообщить("Соединение не удалось");
Возврат;
КонецЕсли;
//подключаем справочник ОС и бух итоги
ит=БДБух.CreateObject("БухгалтерскиеИтоги");
ит.ПериодМ('2011.12.01');
спр=БДБух.CreateObject("Справочник.ОсновныеСредства");
//получаем документ для обработки
редДок=Документы.ВводНачальныхОстатков.ПолучитьСсылку(док.УникальныйИдентификатор()); //НайтиПоНомеру(док.Номер)


Для Каждого стр из редДок.ОС Цикл
инв=стр.ИнвентарныйНомерРегл;
имя=стр.ОсновноеСредство.ПолноеНаименование();
Если спр.НайтиПоКоду(инв,0)=1  Тогда
Если спр.ПолноеНаименование()=имя Тогда
стр.НакопленнаяАмортизацияБУ=ит.СКК(БДБух.EvalExpr("СчетПоКоду(""02.1"")"),"С","",спр.ТекущийЭЛЕМЕНТ());
стр.НакопленнаяАмортизацияНУ=ит.СКК("Н05.02","С","",спр.ТекущийЭЛЕМЕНТ());
стр.ПервоначальнаяСтоимостьБУ=ит.СКД("01.1","С","",спр.ТекущийЭЛЕМЕНТ());
            стр.ПервоначальнаяСтоимостьБУ=ит.СКД("Н05.01","С","",спр.ТекущийЭЛЕМЕНТ());
иначе
Сообщить("Строка "+редДок.ОС.номерСтроки+" инвентарные номера совпали, но не совпали наименования ОС в базах");
КонецЕсли;
иначе
Сообщить("Строка "+редДок.ОС.номерСтроки+" инвентарный номер "+инв+" в базе 7й версии не найден");
КонецЕсли;


КонецЦикла;
РедДок.записать();

КонецПроцедуры

Все заканчивается сообщением об ошибке
{Форма.Форма.Форма(31)}: Поле объекта недоступно для записи (НакопленнаяАмортизацияБУ)
            стр.НакопленнаяАмортизацияБУ=ит.СКК(БДБух.EvalExpr("СчетПоКоду(""02.1"")"),"С","",спр.ТекущийЭЛЕМЕНТ());

Я понимаю, что дико туплю, но с восьмеркой знаком менее двух недель, так что помогите люди добрые, чего я делаю не так??!!!


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Если редДок имеет тип ДокументСсылка, то необходимо для изменения получить объект документа
редДокСсылка=Документы.ВводНачальныхОстатков.ПолучитьСсылку(док.УникальныйИдентификатор()); //НайтиПоНомеру(док.Номер)
редДок = редДокСсылка.ПолучитьОбъект();
//ну и далее по тексту

Оффлайн EnigMan

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-17
  • Сайт: 
  • Профессия: Бухгалтер
Спасибо!!!
С Вашей помощью это
редДок=Документы.ВводНачальныхОстатков.ПолучитьСсылку(док.УникальныйИдентификатор()); 
упростилось до
редДок=док.ПолучитьОбъект();
и заработало как ожидалось.
док - реквизит формы, в котором пользователь выбирает обрабатываемый документ.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5559
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4386
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
53 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 251
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal