Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 15:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как активизировать процедуру ВнешнееСобытие() для формы?  (Прочитано 12701 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Все перерыл. Так и не смог понять когда срабатывает эта процедура.
Ну например на форме документа Приходная накладная написал процедуру:
Код
Процедура ВнешнееСобытие(Источник, Событие, Данные)
   // Insert handler code.
   Сообщить("Ураааа");
КонецПроцедуры


Теперь в каких случаях будет выдано сообщение "Ураааа"?
Открыл Приходную накладную, попробовал нажать клавишу - не сработала, попробовал ввод со сканера - тоже ничего.
Кто объяснит когда и при каких условиях начинает работу эта процедура?
Заранее благодарен.


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
В свойствах управляемой формы должен быть подключен обработчик события ВнешнееСобытие. Подключал?
Кнопочка Спасибо - слева!

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за отклик.
Да, если я Вас правильно понял. Выше приведенный текст как раз и стоит под этим событием.
Хочу еще добавить, что у меня версия 8.1.

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Скажите вот это надо делать в 1с для того, чтобы перехватывать события?
//Компонента AddHook.dll служит для перехвата событий клавиатуры.
//Подключение внешней компоненты AddHook.dll должно находиться в процедуре "ПриНачалеРаботыСистемы" или "ПриОткрытии".
//Переменную "GlobalReg" нужно объявить в глобальном модуле (Перем GlobalReg Экспорт;).
Процедура ПриНачалеРаботыСистемы()
    ЗагрузитьВнешнююКомпоненту("AddHook.dll");
    GlobalReg = Новый("AddIn.AddHookExtension");
    GlobalReg.HookEnabled = 1;    // Включаем Hook
КонецПроцедуры


//В процедуре "ПередЗавершениемРаботыСистемы" необходимо отключить внешнюю компоненту AddHook.dll
Процедура ПередЗавершениемРаботыСистемы(Отказ)
    GlobalReg.HookEnabled = 0;
    GlobalReg = 0;
КонецПроцедуры


//Обработка событий клавиатуры должна находиться в процедуре "ВнешнееСобытие(Источник, Событие, Данные)"
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Если Данные = "00038" Тогда
        Сообщить("Нажата кнопка Стрелка вверх");
    КонецЕсли;
КонецПроцедуры

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Я имею ввиду первые два модуля.

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Спасибо всем. Кажется нашел.
Надо подключать перехватчик события.


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 277
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4806
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3403
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4980
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 580
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 854
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal