Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 10:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Команда Сформировать Из Ут10 В Ут11  (Прочитано 1512 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн serq82

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-25
  • Сайт: 
  • Профессия: Бухгалтер
доброе утро!
только начал изучать 1с, в УТ 10 делал документ ЗаданиеНаПроизводство, в ЗаказПокупателя добавлял кнопку СформироватьЗаданиеНаПроизводствоНажатие, вот код
Процедура СформироватьЗаданиеНаПроизводствоНажатие(Элемент)
МассивВидовПрофилей = Новый Массив;
 
Для Каждого СтрокаТЧ Из Товары Цикл
  НайденныйВидПрофиля = МассивВидовПрофилей.Найти(СтрокаТЧ.Номенклатура.ВидПрофиля);
  Если НайденныйВидПрофиля = Неопределено Тогда
   МассивВидовПрофилей.Добавить(СтрокаТЧ.Номенклатура.ВидПрофиля);
  КонецЕсли;
КонецЦикла;

Для Каждого ЭлементМассива Из МассивВидовПрофилей Цикл
  СоздатьДокументЗаданиеНаПроизводство(ЭлементМассива);
КонецЦикла;

КонецПроцедуры
тут у меня смотря по какой ВидПрофиля для каждого создавался документ ЗаданиеНаПроизводство, ну и сам документ
Процедура СоздатьДокументЗаданиеНаПроизводство(ЭлементМассива)

ЗаданиеНаПроизводство = Документы.ЗаданиеНаПроизводство.СоздатьДокумент();
//ЗаданиеНаПроизводство.Номер  = Номер;
ЗаданиеНаПроизводство.Дата = ТекущаяДата();
ЗаданиеНаПроизводство.ДокументОснование  = Ссылка;
ЗаданиеНаПроизводство.ДатаОтгрузки = ДатаОтгрузки;
ЗаданиеНаПроизводство.Контрагент = Контрагент;
//ЗаданиеНаПроизводство.Организация = Организация;
ЗаданиеНаПроизводство.Подразделение = Подразделение;
ЗаданиеНаПроизводство.Комментарий = Комментарий;
Для Каждого СтрокаТЧ Из Товары Цикл
 
  Если СтрокаТЧ.Номенклатура.ВидПрофиля <> ЭлементМассива Тогда
   Продолжить;
  КонецЕсли;
  СтрокиТабл = ЗаданиеНаПроизводство.Товары.Добавить();
  СтрокиТабл.Номенклатура = СтрокаТЧ.Номенклатура;
  СтрокиТабл.Длина = СтрокаТЧ.Длина;
  СтрокиТабл.Ширина = СтрокаТЧ.Ширина;
  СтрокиТабл.Количество = СтрокаТЧ.Количество;
КонецЦикла;
ЗаданиеНаПроизводство.Записать(РежимЗаписиДокумента.Запись);

КонецПроцедуры;
подскажите как мне теперь все это перенести в УТ 11, в управляемую форму?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Переписать разбивая на директивы компиляции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 817
Последний ответ 24 Янв 2018, 02:38
от Геннадий ОбьГЭС
УТ11.1 - Условие уменьшения скидки: "Если одна из форм оплаты в чеке - Платежная карта"

Автор lsiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2752
Последний ответ 17 Сен 2014, 13:22
от lsi
УТ11.1 Ошибка "Предопределенный элемент не уникален"

Автор pavel-PРаздел Пользователям "1С - Предприятие 8"

Ответов: 8
Просмотров: 8406
Последний ответ 21 Янв 2015, 07:35
от pavel-P
УТ11.1 ГрупповоеИзменениеРеквизитов. Ошибка :"Значение не является значением объектного типа (Ссылка)"

Автор pavel-PРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2640
Последний ответ 21 Янв 2015, 14:10
от pavel-P
УТ11 форма подбора товара - редактирование, Добавить колонку "Доступно"!

Автор MEWРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 14142
Последний ответ 25 Авг 2011, 12:34
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal