Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите найти ошибку модуле формы  (Прочитано 4534 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
В ДОКУМЕНТЕ "Квитанция по договору при изменении Договора выскакивает ошибка


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ошибка вот тут:
&НаСервереБезКонтекста
Функция ПолучитьЗначениеТарифа(Месяц, Год, Тариф ,ТекДата)
ОтборВеличиныТарифа = Новый Структура("НомерМесяца", Месяц, "Год", Год, "ВидТарифа", Тариф);
ЗначениеРесурсов = РегистрыСведений.Тарифы.ПолучитьПоследнее(ТекДата, ОтборВеличиныТарифа);
//Запрос = Новый Запрос;
//Запрос.Текст = "ВЫБРАТЬ *
//|ИЗ РегистрСведений.Тарифы
//|ГДЕ ВидТарифа = &НазваниеТарифа И
//|НомерМесяца = &Месяц И
//|Год = &Год";
//Запрос.УстановитьПараметр("НазваниеТарифа", ДоговорУчащегося.ВидТарифа);
//Запрос.УстановитьПараметр("Месяц", Месяц);
//Запрос.УстановитьПараметр("Год", Год);
//Результат = Запрос.Выполнить().Выбрать();
//Если Результат.Следующий() > 0 Тогда
// Возврат Результат.Стоимость;
//КонецЕсли;
   Возврат ЗначениеРесурсов.Стоимость;


КонецФункции // ПолучитьЗначениеТарифа()
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Что это за структура такая??????????????????????????????? ЧИТАЙ СИНТАКСИС ПОМОЩНИК!!!!!!!!! ТАм есть примеры!!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот так:
ОтборВеличиныТарифа = Новый Структура("НомерМесяца,Год,ВидТарифа");
ОтборВеличиныТарифа.НомерМесяца = Месяц;
ОтборВеличиныТарифа.Год = Год;
ОтборВеличиныТарифа.ВидТарифа = Тариф;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
та же ошибка

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Да ты там не понятно что еще в параметр МЕСЯЦ передаешь!!!! Ваще пдц!!!!!!!!!!!!!!
Пиши вот так и отлаживай сиди!!! Надо ж голову включать иногда!!!!
&НаСервереБезКонтекста
Функция ПолучитьЗначениеТарифа(Месяц, Год, Тариф ,ТекДата)
ОтборВеличиныТарифа = Новый Структура("НомерМесяца,Год,ВидТарифа");
ОтборВеличиныТарифа.НомерМесяца = Месяц;
ОтборВеличиныТарифа.Год = Год;
ОтборВеличиныТарифа.ВидТарифа = Тариф;
ЗначениеРесурсов = РегистрыСведений.Тарифы.ПолучитьПоследнее(ТекДата, ОтборВеличиныТарифа);
//Запрос = Новый Запрос;
//Запрос.Текст = "ВЫБРАТЬ *
//|ИЗ РегистрСведений.Тарифы
//|ГДЕ ВидТарифа = &НазваниеТарифа И
//|НомерМесяца = &Месяц И
//|Год = &Год";
//Запрос.УстановитьПараметр("НазваниеТарифа", ДоговорУчащегося.ВидТарифа);
//Запрос.УстановитьПараметр("Месяц", Месяц);
//Запрос.УстановитьПараметр("Год", Год);
//Результат = Запрос.Выполнить().Выбрать();
//Если Результат.Следующий() > 0 Тогда
// Возврат Результат.Стоимость;
Если ЗначениеРесурсов = Неопределено Тогда
ВызватьИсключение "Бля опять я накосячиЛ!!!!!!";
КонецЕсли;
//КонецЕсли;
   Возврат ЗначениеРесурсов.Стоимость;


КонецФункции // ПолучитьЗначениеТарифа()
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Не верно построен отбор!!!! Смотри в эту сторону!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Сопоставление типов!!! Месяц в регистре = ЧИСЛО!!!!!!!!! Месяц в коде(как входящий параметр) = СправочникСсылка;
Как можно ссылку сравнить с числом?????????????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ты сам хочешь задачу сделать или слить ее на кого нибудь?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
стараюсь ,но никак не пойму


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5552
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5888
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4368
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1979
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 388
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal