Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2018, 00:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: отличия 8.1 от 8.2  (Прочитано 6132 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
есть рабочая процедура,разработанная в платформе 8.1:

Процедура ДанныеОТовареТоварПриИзменении(Элемент)
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
            |         Товары.Ссылка,
            |         Товары.Цена
            |      ИЗ
            |         Справочник.Товары КАК Товары
            |      ГДЕ   Товары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка",Элемент.Значение);

    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Выборка.Следующий();
    ЭлементыФормы.ДанныеОТоваре.ТекущаяСтрока.Цена=Выборка.Цена;

КонецПроцедуры



В платформе 8.2 она не работает.Подскажите что нужно изменить


Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: отличия 8.1 от 8.2
« Ответ #1: 13 Янв 2012, 18:53 »
В 8.2 нет ЭлементыФормы, а есть Элементы
Кнопочка Спасибо - слева!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Re: отличия 8.1 от 8.2
« Ответ #2: 13 Янв 2012, 18:55 »
делал вместо ЭлементыФормы просто Элементы .все равно не работает

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Re: отличия 8.1 от 8.2
« Ответ #3: 13 Янв 2012, 18:57 »
Процедура ДанныеОТовареТоварПриИзменении(Элемент)
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
            |         Товары.Ссылка,
            |         Товары.Цена
            |      ИЗ
            |         Справочник.Товары КАК Товары
            |      ГДЕ   Товары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка",Элемент.Значение);

    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Выборка.Следующий();
    Элементы.ДанныеОТоваре.ТекущаяСтрока.Цена=Выборка.Цена;

КонецПроцедуры



НЕ РАБОТАЕТ! Ещё надо что-то менять. Может Нужны 2 процедуры: на клиенте и на сервере?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: отличия 8.1 от 8.2
« Ответ #4: 13 Янв 2012, 19:56 »
Получаешь цена в функции с инструкцией препроцессора &НаСервереБезКонтекста, присваиваешь &НаКлиенте

Кнопочка Спасибо - слева!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Re: отличия 8.1 от 8.2
« Ответ #5: 13 Янв 2012, 20:01 »
&НаКлиенте
Процедура ДанныеОТовареТоварПриИзменении(Элемент)
   ПолучитьЦену();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ПолучитьЦену()
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
            |         Товары.Ссылка,
            |         Товары.Цена
            |      ИЗ
            |         Справочник.Товары КАК Товары
            |      ГДЕ   Товары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка",Элемент.Значение);

    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Выборка.Следующий();
    Элементы.ДанныеОТоваре.ТекущаяСтрока.Цена=Выборка.Цена;

КонецПроцедуры


Так тоже НЕ ВЫХОДИТ!!!! :(

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: отличия 8.1 от 8.2
« Ответ #6: 13 Янв 2012, 20:13 »
Форма управляемая? Примерно так
&НаКлиенте
Процедура ДанныеОТовареТоварПриИзменении(Элемент)
ТД = Элементы.ДанныеОТоваре.ТекущиеДанные;
ТД.Цена = ПолучитьЦену(ТД.Номенклатура);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьЦену(Номенклатура)
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
            |         Товары.Ссылка,
            |         Товары.Цена
            |      ИЗ
            |         Справочник.Товары КАК Товары
            |      ГДЕ   Товары.Ссылка = &Ссылка";
    Запрос.УстановитьПараметр("Ссылка",Номенклатура);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Выборка.Следующий();
    Возврат Выборка.Цена;
КонецФункции
Кнопочка Спасибо - слева!

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Re: отличия 8.1 от 8.2
« Ответ #7: 13 Янв 2012, 20:20 »
выдает ошибку

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Re: отличия 8.1 от 8.2
« Ответ #8: 13 Янв 2012, 20:24 »
исправь ТД.Цена = ПолучитьЦену(ТД.Номенклатура); на ТД.Цена = ПолучитьЦену(ТД.Товар);
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
93 Сообщений
AIFrame
75 Сообщений
alex0402
32 Сообщений
pavl_vs
23 Сообщений
kiksi
22 Сообщений
andron81_81
18 Сообщений
alexandr_ll
17 Сообщений
Norfolk
15 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений
LexaK
12 Сообщений

* Кто онлайн

  • Точка Гостей: 264
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal