Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с выводом секций в отчете  (Прочитано 2847 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pilot741

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-01
  • Сайт: 
  • Профессия: Программист 7.7
Всем привет.

Помогите справиться с отчетом. Главное выводит нужные данные, но как-то коряво.

Конфа самописная.  Вот код отчета:

Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;   

//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Док = Регистр.ОстатокВБаке.Докум; 
|ДвижДокумент = Регистр.остатокВБаке.ТекущийДокумент; 
|Транспорт = Регистр.ОстатокВБаке.Транспорт;
|Госномер = Регистр.ОстатокВБаке.ГосНомер;
|МаркаГорючего = Регистр.ОстатокВБаке.МаркаГорючего;
|Остаток = Регистр.ОстатокВБаке.Остаток; 
        |Группировка Транспорт;
|Группировка МаркаГорючего упорядочить по МаркаГорючего.Наименование без групп;
|Функция НачальныйОстаток = НачОст(Остаток);
    |Функция КонечныйОстаток =КонОст(Остаток);
    //|Функция НачальныйМаркаГорючего = МаркаГорючего(Значение);
    |"//}}ЗАПРОС
;   

Если ВыбМаркаМашины.Выбран()=1 Тогда
ТекстЗапроса = ТекстЗапроса + "Условие(Транспорт = ВыбМаркаМашины);
|";//}}ЗАПРОС
КонецЕсли;
   
//Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;   
     
// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
Таб.ВывестиСекцию("Шапка");
Состояние("Заполнение выходной таблицы...");

Пока Запрос.Группировка("Транспорт")=1 Цикл
       Таб.ВывестиСекцию("Остаток");
    Пока Запрос.Группировка("МаркаГорючего")=1 Цикл
Таб.ВывестиСекцию("ГСМ");
        КонецЦикла; 
КонецЦикла;
               
Таб.ВывестиСекцию("Подвал");
//Таб.ВывестиСекцию("Итого");
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры

выводит вот что:


какая-то пустая строка образовывается.



Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Итоги наверное накапливаются - попробуй добавить в запрос Без Итогов
Кнопочка Спасибо - слева!

Оффлайн Pilot741

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-01
  • Сайт: 
  • Профессия: Программист 7.7

Оффлайн Pilot741

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-01
  • Сайт: 
  • Профессия: Программист 7.7
Итоги наверное накапливаются - попробуй добавить в запрос Без Итогов

нет, вообще ничего не выводит. только шапку(


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 323
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal