Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Табличный документ  (Прочитано 1155 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Объсните,почему при выводе печатной формы у меня дублируются ОРГАНИЗАЦИЯ,ГОРОД,ЦЕЛЬ на каждую добавляемую строку.


&НаКлиенте
Процедура Сформировать(Команда)
   ТабДок = Новый ТабличныйДокумент;
   ПечатьЗаявки(ТабДок);
   ТабДок.Показать();
КонецПроцедуры

&НаСервере
Процедура ПечатьЗаявки(ТабДок)
 Макет = Документы.ЗаявкиНаКомандировку.ПолучитьМакет("Макет");
 Шапка = Макет.ПолучитьОбласть("Шапка");
 Шапка.Параметры.Менеджер = Объект.Менеджер;
 Шапка.Параметры.Дата1 = Объект.Дата1;
 ТабДок.Вывести(Шапка);
 Данные = Макет.ПолучитьОбласть("Данные");
 Для Каждого СтрТабличнаяЧасть ИЗ Объект.Сведения Цикл
    НомерСтроки = СтрТабличнаяЧасть.НомерСтроки;
    Организация = СтрТабличнаяЧасть.Организация;
    Город = СтрТабличнаяЧасть.Город;
    Цель = СтрТабличнаяЧасть.Цель;

    Данные.Параметры.НомерСтроки = НомерСтроки;
    Данные.Параметры.Организация = Организация;
    Данные.Параметры.Город = Город;
    Данные.Параметры.Цель = Цель;
   
 ТабДок.Вывести(Данные);
     КонецЦикла;
 Подвал = Макет.ПолучитьОбласть("Подвал");
 ТабДок.Вывести(Подвал);   
КонецПроцедуры // ПечатьЗаявки()


Оффлайн artm81

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2010-08-03
  • Сайт: 
Вопрос закрыт :)


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 250
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4414
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9396
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3956
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19093
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 189
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal