Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не находит поля  (Прочитано 2404 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LexaDF

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-14
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток! Столкнулся с проблемой, перевел 1С 8.1 ред. 1.6 в 8.2 ред 2.0 все роде бы ничего но тут наткнулся на подводные камни. Один из них внешние обработки. Переконвертировал их из 8.1 в 8.2 , начал проверять их работоспособность и получил несколько  ошибок, пробовал исправить но так и не получилось  :dfbbdrfb:     :
КонецЕсли;
Перемещение.Номер = НомерДокумента;
Перемещение.Дата = ДатаДокумента;
Перемещение.Организация = Справочники.Организации.НайтиПоКоду("00001");
Перемещение.Ответственный = Ответственный;
[color=red]Перемещение.ОтражатьВНалоговомУчете = Истина;    // не находит поле[/color]
Перемещение.Комментарий = "Загружен из Производства";
СкладОтправительПР = XMLУзел.getAttribute("СкладОтправитель");

СкладОтправительБУХ = ТаблицаСкладов.Найти(СкладОтправительПР,"КодПроизводство");
Если СкладОтправительБУХ = Неопределено Тогда
Сообщить("В документе №" + НомерДокумента + " от " + Строка(ДатаДокумента) + " не указан склад.");
Продолжить;
КонецЕсли;
Перемещение.СкладОтправитель = Справочники.Склады.НайтиПоКоду(СкладОтправительБУХ.КодБухгалтерия);
СкладПолучательПР = XMLУзел.getAttribute("СкладПолучатель");
СкладПолучательБУХ = ТаблицаСкладов.Найти(СкладПолучательПР,"КодПроизводство");
Перемещение.СкладПолучатель  = Справочники.Склады.НайтиПоКоду(СкладПолучательБУХ.КодБухгалтерия);
Перемещение.Товары.Очистить();
Для каждого ТЧ из XMLУзел.childNodes Цикл
НоваяСтрока = Перемещение.Товары.Добавить();
НоменклатураПР = ТЧ.getAttribute("Номенклатура");
НоменклатураБУХ = ТаблицаСырья.Найти(НоменклатураПР,"КодПроизводство");
Если НоменклатураБУХ = Неопределено Тогда
Сообщить("В документе №" + НомерДокумента + " от " + Строка(ДатаДокумента) + " указана неизвестная номенклатура.");
НеЗаписывать = Истина;
Продолжить;
КонецЕсли;
ГруппаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию("Мясосырье");
НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(НоменклатураБУХ.КодБухгалтерия,,ГруппаНоменклатуры);
Если НоваяСтрока.Номенклатура.Наименование = "" Тогда
ГруппаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию("Добавки");
НоваяСтрока.Номенклатура = Справочники.Номенклатура.НайтиПоКоду(НоменклатураБУХ.КодБухгалтерия,,ГруппаНоменклатуры);
Если НоваяСтрока.Номенклатура.Наименование = "" Тогда
НеЗаписывать = Истина;
Сообщить("В документе №" + НомерДокумента + " от " + Строка(ДатаДокумента) + " указана неизвестная номенклатура.");
КонецЕсли;
КонецЕсли;
НоваяСтрока.Количество = ТЧ.getAttribute("Количество");
Если НоваяСтрока.Количество = 0 Тогда
НеЗаписывать = Истина;
Сообщить("В документе №" + НомерДокумента + " от " + Строка(ДатаДокумента) + " не указано количество.");
КонецЕсли;
[color=red]НоваяСтрока.СчетУчетаБУ = ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.01");           // не находит поле
    НоваяСтрока.НовыйСчетУчетаБУ = ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.01");
НоваяСтрока.СчетУчетаНУ = ПланыСчетов.Налоговый.НайтиПоКоду("10.01");
НоваяСтрока.НовыйСчетУчетаНУ = ПланыСчетов.Налоговый.НайтиПоКоду("10.01");[/color]


При активации загрузки он выдает следущее :
{Форма.Форма.Форма(82)}: Поле объекта не обнаружено (ОтражатьВНалоговомУчете)
      Перемещение.ОтражатьВНалоговомУчете = Истина;


или

{Форма.Форма.Форма(120)}: Поле объекта не обнаружено (СчетУчетаБУ)
         НоваяСтрока.СчетУчетаБУ = ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.01");


Не знаю что делать уже :( а просят срочно нужно выгрузить данные  :(( посоветуйте  пожалуйста!!!



Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Не находит поля
« Ответ #1: 11 Янв 2012, 18:09 »
Ну ты посмотри эти реквизиты то есть у документ или нет!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2467
Последний ответ 31 Дек 2011, 11:36
от AntonB
Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6846
Последний ответ 24 Ноя 2014, 12:21
от gigson
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3215
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8488
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 210
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal