Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 03:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Слишком много фактических ошибок  (Прочитано 4750 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sachok7778

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-10-06
  • Сайт: 
  • Профессия: Программист 8.1
При запуске тип.конфига "УНФ"(демо) в польз. режиме сообщает:

"{ОбщийМодуль.РезервноеКопированиеИБКлиентГлобальный(17,65)}: Слишком много фактических параметров (Вопрос)
Нстр("ru = 'Провести резервное копирование прямо сейчас'"), <<?>>КодВозвратаДиалога.Да);

Что мне надо исправить чтобы база заработала


Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Во-первых НСтр тебе не нужен, т.к. ты все равно там ставишь только один язык, поэтому можно его убрать. Плюс к тому не "КодВозвратаДиалога.Да", а "РежимДиалогаВопрос.Да", но поскольку у тебя все равно тут нету Да/нет, то проще воспользоваться просто Предупреждение(), т.е.:
//т.к. предупреждение, вопрос и сообщить не используются в модуле внешнего соединения, то:
#Если Клиент Тогда
Предупреждение("Провести резервное копирование прямо сейчас");
#КонецЕсли

Но это тоже не логично, т.к. судя по тексту ты же задаешь пользователю вопрос и смотришь ответит ли он да или нет, отсюда мы получаем следующее:

//для того чтобы не ругалось, что переменная не определена в модуле внешнего соединения:
Ответ = "";

#Если Клиент Тогда
Ответ = Вопрос("Провести резервное копирование прямо сейчас",РежимДиалогаВопрос.ДаНет);
#КонецЕсли
Если Ответ = КодВозвратаДиалога.Да Тогда //вот где используется КодВозвратаДиалога - это возвращаемый вопросом тип.
//А вот тут уже модель того, что должно быть если пользователь ответил "Да"
КонецЕсли;


Теги:
 

опять вопрос про "много" реквизитов в справочнике (или документе)

Автор andron81_81Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 444
Последний ответ 08 Дек 2017, 07:54
от andron81_81
Перешли на 8УТ с ТИСа, работаем первую неделю. Есть много вопросов. На те, что не нашел ответы в интернете подскажите пожалуйста, опытом поделитесь))

Автор KofffeРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1182
Последний ответ 02 Ноя 2015, 12:34
от AIFrame
Отразить в ЗУП факт признания ПФР-ом переплаты, сделанной много месяцев назад

Автор VdegРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2272
Последний ответ 02 Июн 2011, 10:12
от Шурыгин Иван Сергеевич
в Win8 при работе кассы 1С:Предприятие 8.2 (8.2.19.68) Фронт появляется много процессов 1с

Автор mars551Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1598
Последний ответ 21 Май 2014, 14:33
от mars551
Нужно очень много помощи, в выпускной работе по 1с предприятию 8.1.

Автор Artem_KovalevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1467
Последний ответ 21 Апр 2014, 23:54
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
27 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 161
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal