Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Янв 2018, 08:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при заполнении реквизитов формы 8.2  (Прочитано 2798 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн trilobit

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
В форме документа при заполнении контактного лица необходимо, чтобы заполнялся контактный телефон из справочника. я пишу код

&НаКлиенте
Процедура ФИОПокупателяПриИзменении(Элемент)
Объект.Телефон = ПолучаемКонтактныйТелефон(Объект.Телефон);
КонецПроцедуры


&НаСервере
Функция ПолучаемКонтактныйТелефон(КонтактныеЛица);

Возврат КонтактныеЛица.Телефон;

КонецФункции


А он мне ошибку: Значение не является значением объектного типа (Телефон)
   Возврат КонтактныеЛица.Телефон;


Подскажите, пожалуйста, в чём проблема?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ты на код то хоть смотришь?
Херня какая то написана.
Где телефон то находиться? В Объекте? или нет?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн trilobit

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Телефон находиться в реквизите справочника(КонтактныеЛица.Телефон). Необходимо из данных этого справочника заполнить Объект.Телефон, соответствующий выбранному КонтактныеЛица.Наименование. В чём херня то?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ФИОПокупателяПриИзменении(Элемент)
    Объект.Телефон = ПолучаемКонтактныйТелефон(Объект.Клиент);
КонецПроцедуры


&НаСервере
Функция ПолучаемКонтактныйТелефон(КонтактныеЛица);
   
    Возврат КонтактныеЛица.Телефон;
   
КонецФункции   
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн trilobit

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-09
  • Сайт: 
  • Профессия: Ученик 1С
Благодарю, не допёр, что нужно передавать имя клиента)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Не имя, а ссылку.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4690
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6275
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8983
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8755
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
AIFrame
71 Сообщений
alex0402
32 Сообщений
kiksi
27 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 199
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal