Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 20:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поле объекта не обнаружено (ТекущиеДанные)  (Прочитано 7915 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Код:
&НаСервере
 Процедура РассчитатьН()
        СтрокаТаблЧасти = Объект.Таблица.ТекущиеДанные;     
Если СтрокаТаблЧасти.Вещество.Наименование = "Взвешенные вещества" Тогда
СтрокаТаблЧасти.Н = 30
        КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ТаблицаВеществоПриИзменении()
  РассчитатьН()
КонецПроцедуры

При выборе элемента в колонке "вещество" в табличной части документа выводит ошибку "Поле объекта не обнаружено (ТекущиеДанные)" . в чем ошибка?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну как на сервере могут быть ТекущиеДанные? Ты мне можешь сказать? Откуда СЕРВЕР знает где у тебя курсор на форме стоит????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Попробуй вот так
&НаСервере
 Процедура РассчитатьН(СтрокаТаблЧасти )
    Если СтрокаТаблЧасти = Неопределено Тогда
          Возврат;
    КонецЕсли;
                                  
    Если СтрокаТаблЧасти.Вещество.Наименование = "Взвешенные вещества" Тогда
        СтрокаТаблЧасти.Н = 30
    КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ТаблицаВеществоПриИзменении()
      РассчитатьН(Элементы.ТЧ.ТекущиеДанные);
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Такой вариант рассматривался изначально, но выдает ошибку отображения типов,
объяснить не могу иначе задавать судя по всему глупые вопросы на форуме и не приходилось бы


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7838
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 636
Последний ответ 10 Окт 2017, 12:33
от kiksi
Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 312
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 272
Последний ответ 03 Мар 2018, 16:14
от useronforum
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 7441
Последний ответ 10 Июл 2014, 15:16
от virtus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 259
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal