Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июн 2018, 11:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по типу результата запроса  (Прочитано 3802 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Erroshka

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-28
  • Сайт: 
  • Профессия: Ученик 1С
На форме отчета есть комбобокс, в его обработчике события при изменении написала запрос, а потом так:
Результат = Запрос.Выполнить().Выгрузить();
И тип результата почему-то "ТабличныйДокумент", хотя точно такой же запрос был на форме для документа, и там тип результата был "ТаблицаЗначений".
А я хочу подоставать из запроса что-нибудь, вот из ТЗ умею, а из ТД не знаю как
 :dfbsdfbsdf: :dfbsdfbsdf:


Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Не-не, мистика какая-то, давай скидывай всю процедуру, потому как метод Выгрузить() дает типы только ТаблицаЗначений или ДеревоЗначений.

Оффлайн Erroshka

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-28
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Функция ОтправитьЗапрос( Текст, Параметр )
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр( "Параметр", Параметр );
   Запрос.Текст = Текст;
   Результат = Запрос.Выполнить().Выгрузить(); // Вот тут тип результата именно ТабличныйДокумент!
   Возврат ВМассивСтрок( Результат );
КонецФункции
...
ТекстЗапроса = "ВЫБРАТЬ
            |   Студенты.Ссылка
            |ИЗ
            |   Справочник.Студенты КАК Студенты
            |ГДЕ
            |   Студенты.Владелец = &Параметр";
         
РезультатЗапроса = ОтправитьЗапрос( ТекстЗапроса, Отчет.Группа );

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А что такое ВМассивСтрок( результат ) ???
Можно посмотреть код этой функции???
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Erroshka

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Да это конечно) Где-то нашла такой способ на просторах интернета. Но суть не в этой функции, а выше на строку!
Функция ВМассивСтрок( Результат )
   СтрокаСтруктуры = "";
    МассивКолонок = Новый Массив;
    Для каждого Рез из Результат.Колонки Цикл
        Если НЕ СтрокаСтруктуры = "" Тогда
            СтрокаСтруктуры = СтрокаСтруктуры + ", ";
        КонецЕсли;
        СтрокаСтруктуры = СтрокаСтруктуры + Рез.Имя;
        МассивКолонок.Добавить(Рез.Имя);
    КонецЦикла;
    МассивСтрок = Новый Массив;
    Для каждого Рез из Результат Цикл
        СтруктураСтроки = Новый Структура(СтрокаСтруктуры);
        Для каждого кол из МассивКолонок Цикл
            СтруктураСтроки.Вставить(кол, Рез[кол]);
        КонецЦикла;
        МассивСтрок.Добавить(СтруктураСтроки);
    КонецЦикла;
    Возврат МассивСтрок;
КонецФункции

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
читай СП - метод "выгрузить() для запроса"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Erroshka

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Ребята, хелп прочитала, но вот пруф что тип у результата именно ТабличныйДокумент.
Повторюсь, что этот запрос из отчета, а такой же запрос, но из документа работает именно как вы и пишете.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Странно конечно.
напиши не "Результат"а например - МойРезультат = Запрос.Выполнить().Выгрузить(); и посмотри что получиться.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Скорее всего переменная определена еще до исполнения твоего запроса
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Erroshka

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Скорее всего переменная определена еще до исполнения твоего запроса
Да! Так оно и получилось видимо! Теперь все работает, огромное спасибо! :ehtwj: :ehtwj: :ehtwj:


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 11028
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6397
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3575
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4092
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2785
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
125 Сообщений
AIFrame AIFrame
125 Сообщений
alexandr_ll
61 Сообщений
pavl_vs
50 Сообщений
alex0402
30 Сообщений
buketov.av buketov.av
27 Сообщений
ilyay ilyay
25 Сообщений
magnifico61
21 Сообщений
wise wise
20 Сообщений
trialex3
15 Сообщений

* Кто онлайн

  • Точка Гостей: 288
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal