Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите ! Передача результата запроса в форму списка  (Прочитано 4491 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SergioSS

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-29
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток. О проблеме в двух словах. В форме списка справочника РасходнаяНакладная создал фильтр ВыборТовара, который должен выбирать все РасходныеНакладные, содержащие выбранный товар. Товар в каждой накладной представлен таблицей. В произвольном запросе выбрал РасходныеНакладные с параметром запроса по ВыборТовара. Однако форма списка РасходныхНакладных "слушается" только при указании параметра в фильтре ВыборТовара, а если фильтр не выбран, то список пустой, а я хочу чтобы если ВыборТовара не выбрано, то список должен содержать все. Попробовал сделать запрос не произвольный, а в форме, но не могу результат запроса перенести в форму списка.
Это второй вариант: (второй день бьюсь)

&НаКлиенте
Процедура ВыборТовараПриИзменении(Элемент)
ОтборПоФильтру(ВыборТовара);
КонецПроцедуры


&НаСервереБезКонтекста
Процедура ОтборПоФильтру(Номенклатура)
Запрос = Новый Запрос;
Запрос.Текст =

"ВЫБРАТЬ
| Расходная.Ссылка,
| Расходная.Номер,
| Расходная.Дата,
| Расходная.Контрагент,
| Расходная.Контрагент.Адрес,
| Расходная.СуммаПредоплаты,
| Расходная.ТоварыСумма
| ИЗ
| Документ.Расходная КАК Расходная
| ГДЕ
| Расходная.ТаблТовары.Номенклатура = &Товар";


Запрос.УстановитьПараметр("Товар",Номенклатура);
Результат = Запрос.Выполнить();

Выборка = Результат.Выбрать();

КонецПроцедуры


Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Я тут для примера взял документ "ОчтетОРозничных Продажах", в нем табличная часть есть "Товары"

Процедура ВыборТовараПриИзменении(Элемент)
Если ЗначениеЗаполнено(ВыборТовара) Тогда
ОтборПоФильтру(ВыборТовара);
Иначе
Список.Отбор.Ссылка.Использование = Ложь;
ДокументСписок.Обновить();
КонецПроцедуры

Процедура ОтборПоФильтру(Номенклатура)
Запрос = Новый Запрос("ВЫБРАТЬ
   |   ОтчетОРозничныхПродажахТовары.Ссылка
   |ИЗ
   |   Документ.ОтчетОРозничныхПродажах.Товары КАК ОтчетОРозничныхПродажахТовары
   |ГДЕ
   |   ОтчетОРозничныхПродажахТовары.Номенклатура = &Номенклатура
   |   И ОтчетОРозничныхПродажахТовары.Ссылка.Дата МЕЖДУ &НачПериода И &КонПериода");
   Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
   Запрос.УстановитьПараметр("НачПериода",?(Формат(ЭлементыФормы.Список.СтандартныйПериод.ДатаНачала,"ДП=""пустая""") = "пустая",Дата(1900,01,01),ЭлементыФормы.Список.СтандартныйПериод.ДатаНачала));
   Запрос.УстановитьПараметр("КонПериода",?(Формат(ЭлементыФормы.Список.СтандартныйПериод.ДатаОкончания,"ДП=""пустая""") = "пустая",ТекущаяДата(),ЭлементыФормы.Список.СтандартныйПериод.ДатаОкончания));
   Результат = Запрос.Выполнить().Выбрать();
   СписокДокументов = Новый СписокЗначений;
   Пока Результат.Следующий() Цикл
      СписокДокументов.Добавить(Результат.Ссылка);
   КонецЦикла;
   Список.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
   Список.Отбор.Ссылка.Значение = СписокДокументов;
   Список.Отбор.Ссылка.Использование = Истина;
КонецПроцедуры

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
А дату я туда впигдючил, чтобы сохранялся отбор по выбранному на форме списка периоду.

Оффлайн SergioSS

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-29
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за помощь.
Пробую. Последние три строчки не понимаю:
Список.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
Список.Отбор.Ссылка.Значение = СписокДокументов;
Список.Отбор.Ссылка.Использование = Истина;

Мы ж в данный момент на Сервере. Сервер не понимает "Список"

 

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Управляемые формы или нет??? Вы же нифига не пишете...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн SergioSS

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-29
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Табличная часть товары - динамический список?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Список документов - это в любом случае динамический список, в него новый отбор не добавишь.

А строчки эти:

Список.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
Список.Отбор.Ссылка.Значение = СписокДокументов;
Список.Отбор.Ссылка.Использование = Истина;

Я использовал отбор по списку документов по ссылке, т.е. ссылка на документ в списке, полученном запросом.

Оффлайн SergioSS

  • **
  • Сообщений: 52
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-12-29
  • Сайт: 
  • Профессия: Программист 1С
Табличная часть - это Табличная часть Документа


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5545
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4359
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 338
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal