Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с реестром документов  (Прочитано 5965 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
необходимо добавить в реестр документов суммы по маршрутным  листам (если в них -маршрутных листах есть накладные с
приходниками, если  нет то "0") в колонку сумма см. скан во вложении.
А также в графу  "информация" экспедитора, который указан в маршрутном листе.
Заранее спасибо.


Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Сканер реестра документов для примера. Подскажите кто знает, как это реализовать..

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Видимо здесь неоткого ждать помощи..:(

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
а в какой программе эти маршрутные листы ведутся. ? Может вы вообще их в Экселе ведете... Если вопрос непонятный то какой Вы желаете получить ответ?. Озвучте полностю название конфигурации. А также стандарнтная она или переделанная. Тогда может ктото и поможет.

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Действительно, Володя..Вы правы..Конфигурация стандартная, 1с 7.7 торговля и склад. Реестр документов нажодится в отчете..больше не знаю что добавить..

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Помощь => О Програме.
 Перепишите все что там написано

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
вот какая информация о программе вышла

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Такой конфигугации "Корпоратиывный учет в торговле" я не нашел. Похоже что это нестандартная  конфигурация. (в стандартных в этом месте названия как правило присудствует номер версии.
Что делать дальше?
1. Найти того кто делал эту конфигурацию и попросить его доработать...
2. ждать того кто под разгар Нового Года бросит отмечать его и будет разбиратся в Вашей конфигурации. (но для этого нужно сюда вылолить файл 1cv7.md а также желательно все файлы с папки ExtForms)

Оффлайн Яна93

  • **
  • Сообщений: 97
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • ангелы живут вечно! так что терпите )))
  • Регистрация: 2011-08-31
  • Сайт: 
  • Профессия: Ученик 1С
Да, Володя) действительно запутанная программа)) но я тут за выходный начала разбираться...и вот что выходит...информация и сумма в модуле реестра документов ссылаются на глобальный модуль...где и прописывается код программы...информацию получилось добавить...а вот сумму накладных (реализация) которые относятся к одному маршрутному листу не получается...там видимо нужен замудренный код..просто реализация находится в табличной части маршрутного листа..и у каждой реализации есть своя сумма..а вот как теперь мне до нее добраться, чтобы она в отчете отображалась..я нашла в какой части глобального модуля ее нужно прописать..:

//  глСуммаДокументаВЖурнале(Док, ТипВозврата)
//
// Параметры:
//  Док       - документ
//  ТипВозврата   - строка, тип возвращаемого значения. Может принимать значения:
//                "строка" - сумма по документу в виде отформатированной строки
//                "число"  - сумма по документу в виде числа
//
// Возвращаемое значение:
//  Отформатированная сумма
//
// Описание:
//  Формирует сумму, которая отражается в журналах, реестрах для документа.
//  При формировании суммы по документам "Счет фактура полученный" и "Счет
//  фактура выданный" учитывается то, что в этих документах сумм нет, для них
//  отображается сумма документа - основания.
//
Функция глСуммаДокументаВЖурнале(Док, ТипВозврата="строка") Экспорт
   Перем Результат;
   Перем СуммаНДС;
   Перем СуммаНП;
   
   Результат   =0;
   СуммаНДС   =0;
   СуммаНП    =0;
                  
   Если ПустоеЗначение(Док)=1 Тогда
      Возврат "";
   КонецЕсли;
   
   ВидДок=Док.Вид();
   
   Если ВидДок = "ОтчетКомитенту" Тогда // здесь тяжело считать сумму комиссионного вознаграждения, поэтому вернем пустоту
      Возврат "";
   КонецЕсли;
   
   РеквСумма=Метаданные.Документ(ВидДок).РеквизитШапки("Сумма");
        
   Если (ВидДок = "СчетФактураВыданный")
   или  (ВидДок = "СчетФактураПолученный")
   Тогда       
      Если (Док.ДокОснование.Выбран() = 1)
      и    (Док.КоличествоСтрок() = 0)
      Тогда
          Возврат (глСуммаДокументаВЖурнале(Док.ДокОснование, ТипВозврата));
      КонецЕсли;
   КонецЕсли;
   
   Если РеквСумма.Выбран()=1 Тогда
      Результат= Док.Сумма;
   Иначе
      
      Если "ВводОстатковТМЦ" = ВидДок Тогда
         Если Перечисление.ВидыОперацийПоВводуОстатков.ОстаткиРеализованныхТоваров = Док.ВидОперации Тогда
             Результат=Док.Итог("ПродСтоимость");
         Иначе
            Результат=Док.Итог("СуммаРуб");
         КонецЕсли;
      Иначе
         РеквСумма=Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти("Сумма");
         Если РеквСумма.Выбран()=1 Тогда
            Если РеквСумма.ИтогПоКолонке=1 Тогда
               Результат=Док.Итог("Сумма");
            КонецЕсли;
         Иначе
            РеквСумма=Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти("СуммаРуб");
            Если РеквСумма.Выбран()=1 Тогда
               Если РеквСумма.ИтогПоКолонке=1 Тогда
                  Результат=Док.Итог("СуммаРуб");
               КонецЕсли;                 
            КонецЕсли;
         КонецЕсли;
      КонецЕсли; 
                      
   
      РеквСуммаНДС=Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти("СуммаНДС");
      Если РеквСуммаНДС.Выбран()=1 Тогда
         Если РеквСуммаНДС.ИтогПоКолонке=1 Тогда
            СуммаНДС=Док.Итог("СуммаНДС");
         КонецЕсли;                         
      КонецЕсли;
      
      РеквСуммаВклНДС=Метаданные.Документ(ВидДок).РеквизитШапки("СуммаВклНДС");
      Если РеквСуммаВклНДС.Выбран()=1 Тогда
         Результат=Результат+?(Док.СуммаВклНДС=1,0,СуммаНДС);
      КонецЕсли;
      
      РеквСуммаНП=Метаданные.Документ(ВидДок).РеквизитТабличнойЧасти("СуммаНП");
      Если РеквСуммаНП.Выбран()=1 Тогда
         Если РеквСуммаНП.ИтогПоКолонке=1 Тогда
            СуммаНП=Док.Итог("СуммаНП");
         КонецЕсли;                         
      КонецЕсли;
      
      РеквСуммаВклНП=Метаданные.Документ(ВидДок).РеквизитШапки("СуммаВклНП");
      Если РеквСуммаВклНП.Выбран()=1 Тогда
         Результат=Результат+?(Док.СуммаВклНП=1,0,СуммаНП);
      КонецЕсли;
   КонецЕсли;       
                                
   Если ТипВозврата = "строка" Тогда
       Возврат глФрм(Результат);
   Иначе
      Возврат Результат;
   КонецЕсли;   

   
КонецФункции //глСуммаДокументаВЖурнале()   


Возможно мне в этот код нужно добавить чтото подобное
 (Если "МаршрутныйЛистСтарый" = ВидДок Тогда 
   
          Возврат "";
   
   КонецЕсли; ) только вот не знаю как написать код чтобы сумма реализации отобразилась..может ктото подскажет?

Оффлайн sergejK74

  • *****
  • Сообщений: 1093
  • РЕПУТАЦИЯ: 458
  • КПД: 42%
  • Всегда готов помочь!
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Ученик 1С
Если чисто в лоб, то что то такое должно помочь.
Если "МаршрутныйЛистСтарый" = ВидДок Тогда
Результат = 0; 
док.ВыбратьСтроки();
Пока док.ПолучитьСтроку() = 1 Цикл
Результат = Результат + док.ДокументРеализации.Итог("Сумма");
КонецЦикла;
Возврат Результат;
Вместо ДокументРеализации нужно подставить название реквизита табличной части документа "МаршрутныйЛистСтарый"
Кнопочка Спасибо - слева!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 354
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal