Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 10:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как обратиться к перечислениям?  (Прочитано 15846 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, как обратиться к перечислениям с модуля документа в платформе 8.2?
при варианте -   Перечисления.(Имя перечисления).(Значение перечисления)
выдает, что  "Переменная не определена (Перечисления)  "


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
КакаяВажность = Перечисления.Важность.Высокая;
В вашем случае может быть неопределена переменная "КакаяВажность". А с обращением в перечислению должно быть всё ОК!

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
текст ошибки:
{Документ.СбросВредныхВеществ.Форма.ФормаДокумента.Форма(20,51)}: Переменная не определена (Перечисления)
      Если  СтрокаТаблЧасти.Вещество.КлассОпасности = <<?>>Перечисления.КлассОпасности.I  (Проверка: Тонкий клиент)

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Что за конфигурация, а то в УПП я не вижу такого?

Так вы еще и тонкий клиент используете?

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
это конфа с нуля написанная

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А вот это о чем-нибудь говорит? Я это взял из Синтаксис-помощника.... Тип перечисления у Вас какой? Посмотрите в отладчике? Если будет перечислениеСсылка, тогда доступа на тонком клиенте не будет!

ПеречислениеСсылка.<Имя перечисления>.Метаданные (EnumRef.<Имя перечисления>.Metadata)
ПеречислениеСсылка.<Имя перечисления> (EnumRef.<Имя перечисления>)
Метаданные (Metadata)
Синтаксис:

Метаданные()
Возвращаемое значение:

Тип: ОбъектМетаданных: Перечисление.

Описание:

Предоставляет доступ к объекту описания метаданных перечисления. Другой путь получения того же значения - через свойство глобального контекста Метаданные. Например: Метаданные.Перечисления.ВидыКонтрагентов.

Доступность:

Сервер, толстый клиент, внешнее соединение.



Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
На стороне Клиента это использовать нельзя! Только на стороне Сервера.
Улавливаете разность между &НаСервере и &НаКлиенте?


//Будет работать:
&НаСервере
Процедура Команда1(Команда)
   КлассВажности = Перечисления.Важность.Высокая;
   
КонецПроцедуры
-----------------------------------------------------------------
//Не будет работать:
&НаКлиенте
Процедура Команда1(Команда)
   КлассВажности = Перечисления.Важность.Высокая;
   
КонецПроцедуры

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
при варианте НаСервере тоже не работает, ошибку не выдает, но условия не выполняет

та же проблема с константами, при открытии документа один из реквизитов должен заполнятся значением константы, как это реализовать?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2859
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Выкладывай код, а то гадать что ты там сравниваешь не хочется.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mdn

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-13
  • Сайт: 
  • Профессия: Ученик 1С
Имеем : константа - Кин
реквизит документа - Кин
нужно чтобы при открытии в документе в значение реквизита автоматически вставлялось значение константы
Код:
Процедура ПолучитьКин()
   Кин=Константы.Кин.Получить()
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПолучитьКин()
КонецПроцедуры

аналогично и с первым вопросом, на 8.1 работало, не могу разобраться с Клиент&Сервером


Теги:
 

Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5126
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Как обратиться к "вложенным" реквизитам формы объекта?

Автор Jack_78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 878
Последний ответ 29 Янв 2016, 15:20
от Jack_78
как в цикле обратиться к значениям полей СхемаКомпоновкиДанных и где должна быть размещена обработка при отсутствии формы?

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 2233
Последний ответ 01 Мар 2016, 21:42
от sveta C
За получением имущественного или социального вычета работник может обратиться по месту работы

Автор newsРаздел Новости

Ответов: 0
Просмотров: 380
Последний ответ 25 Фев 2016, 09:37
от news
Как во внешнем отчете обратиться к функции модуля формы этого отчета?

Автор Алексей2014Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 6640
Последний ответ 28 Фев 2016, 23:56
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
106 Сообщений
AIFrame
105 Сообщений
alex0402
28 Сообщений
alexandr_ll
17 Сообщений
kiksi
17 Сообщений
andron81_81
16 Сообщений
BuhRust
13 Сообщений
pavl_vs
13 Сообщений
LexaK
13 Сообщений
Artibon
12 Сообщений

* Кто онлайн

  • Точка Гостей: 970
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal