Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПриВыводеСтроки()  (Прочитано 12874 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
1С 8.1. Есть реквизит "Авторезервирование" (значение Булево) у объекта "ЗаказПокупателя" размещенный в форме "ФормаСписка".
При записи "РеализацияТоваровУслуг" сформированном на основании "ЗаказПокупателя", реквизит "ЗаказПокупателя" = Истина.

Теперь хочу выделить цвет текста объектов "ЗаказПокупателя" в форме списка с условием Авторезервирование=Истина красным цветом. Пишу процедуру в модуле "ФормаСписка" "ЗаказПокупателя"

Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   
   если ДанныеСтроки.АвтоРезервирование Тогда
      ОформлениеСтроки.ЦветТекста = Новый Цвет(255, 0, 0);
   КонецЕсли;
   
КонецПроцедуры

Но никак выделяется цветом. В 1С 8.0 работает процедура. Подскажите где собака зарыта


Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
То есть в 8.1 не выделяется цветом

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
А отладчик что говорит? И процедуру к событию формы привязали?

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
ЦветТекста = WebЦвета.Серый;//или красный, или что там тебе надо
А Новый и цвет - это ты создаешь новый объект.

Оффлайн aaaaaa

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2011-09-30
  • Сайт: 
  • Профессия: Программист 1С
Должно работать.
Просмотрите в отладчике АвтоРезервирование.
Например вот так у меня работает и тоже в 8.1
Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

     Если  ДанныеСтроки.Родитель.Код=0 Тогда
                         ОформлениеСтроки.ЦветТекста=Новый Цвет(255, 255, 0);
   КонецЕсли; 

Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
А отладчик что говорит? И процедуру к событию формы привязали?

А как нужно ее привязать к форме? (я начинающий программист)

Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
ЦветТекста = WebЦвета.Серый;//или красный, или что там тебе надо
А Новый и цвет - это ты создаешь новый объект.
Пробовал итак, не работает

Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
Должно работать.
Просмотрите в отладчике АвтоРезервирование.
Например вот так у меня работает и тоже в 8.1
Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

     Если  ДанныеСтроки.Родитель.Код=0 Тогда
                         ОформлениеСтроки.ЦветТекста=Новый Цвет(255, 255, 0);
   КонецЕсли; 

Отладчиком пользоваться мне пока тоже тяжело

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Посмотри в свойствах поля твоего списка, стоит ли эта процедура в поле "ПриВыводеСтроки"

Оффлайн Гайдар

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
Посмотри в свойствах поля твоего списка, стоит ли эта процедура в поле "ПриВыводеСтроки"

Но я не вижу в свойствах такого события "ПриВыводеСтроки" нигде


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 348
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal