Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 20:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Реквизит справочника в табличную часть документа  (Прочитано 3650 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

Здравствуйте. Есть справочник Фурнитура с реквизитами Наименование и ЕдиницаИзмерения-СправочникСсылка.ЕдиницыИзмерения. И есть документ с табличной частью Фурнитура и реквизитами Наименование - СправочникСсылка.Фурнитура и ЕдиницаИзмерения -СправочникСсылка.Фурнитура. Необходимо, чтобы в документе при выборе фурнитуры подставлялась единица измерения из справочника Фурнитура. Пишу:
&НаКлиенте
Процедура ФурнитураНаименованиеПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Фурнитура.ТекущиеДанные;
СтрокаТабличнойЧасти.ЕдиницаИзмерения = ПолучитьЕдиницу(СтрокаТабличнойЧасти.ЕдиницаИзмерения);
КонецПроцедуры

&НаСервере
Функция ПолучитьЕдиницу(Фурнитура)
Возврат Фурнитура.ЕдиницаИзмерения;
КонецФункции

Ошибки не выдает, но и значение не подставляет. :dfbsdfbsdf:


Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
ну у вас ЕдиницаИзмерения в табличной части "Фурнитура" имеет значение СправочникСсылка.Фурнитура. Т.е. получается, исходя из кода, что вы пытаетеся в тип СправочникСсылка.Фурнитура добавить значение реквизита с типом СправочникСсылка.ЕдиницыИзмерения.
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн beztrud

Но если в табличной части Фурнитура сделать реквизит ЕдиницаИзмерения строкой, то выдает ошибку

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ПолучитьЕдиницу(СтрокаТабличнойЧасти.ЕдиницаИзмерения);
Что это за параметр????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн beztrud

&НаКлиенте
Процедура ФурнитураНаименованиеПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Фурнитура.ТекущиеДанные;
СтрокаТабличнойЧасти.ЕдиницаИзмерения = ПолучитьЕдиницу(Фурнитура);
КонецПроцедуры

&НаСервере
Функция ПолучитьЕдиницу(Фурнитура)
Возврат Фурнитура.ЕдиницаИзмерения;   
КонецФункции


Пишет:

{Документ.ЗаказКвартира.Форма.ФормаДокумента.Форма(57,57)}: Переменная не определена (Фурнитура)
СтрокаТабличнойЧасти.ЕдиницаИзмерения = ПолучитьЕдиницу(<<?>>Фурнитура); (Проверка: Тонкий клиент)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ФурнитураНаименованиеПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Фурнитура.ТекущиеДанные;
СтрокаТабличнойЧасти.ЕдиницаИзмерения = ПолучитьЕдиницу(СтрокаТабличнойЧасти.Номенклатура); //Или товар, или Фурнитура, хз как она там у тебя называется
КонецПроцедуры

&НаСервереБезКонтекста     //Не нужно форму гонять на сервер из за одного реквизита...
Функция ПолучитьЕдиницу(Фурнитура)
Возврат Фурнитура.ЕдиницаИзмерения;   
КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн beztrud

Вот верный код:

&НаКлиенте
Процедура ФурнитураНаименованиеПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Фурнитура.ТекущиеДанные;
СтрокаТабличнойЧасти.ЕдиницаИзмерения = ПолучитьЕдиницу(СтрокаТабличнойЧасти.Наименование);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьЕдиницу(Фурнитура)
Возврат Фурнитура.ЕдиницаИзмерения;
КонецФункции

Спасибо большое.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15947
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4787
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1591
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal