Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Задание типа файла при сохранении таб.документа "Сохранить копию" во внешний фа  (Прочитано 4339 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Marta_Li

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-01
  • Сайт: 
  • Профессия: Программист 8.1
Возможно ли добраться в 1С до формы "Сохранить копию" файла (общее меню "Файл") при сохранении табличного документа (например) во внешний файл для задания расширения сохранения файла по-умолчанию?
Много сохраняется в Exele файлов (отчеты) пользователями, по умолчанию предлагается mxl, а хотелось бы xls.


Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
По-моему нет, но можешь просто добавить на формы своих очень часто сохраняемых отчетов кнопку, которая будет сама схоранять документ сразу в *.xls.

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Выглядеть это будет примерно так:
//Таблица - это твой таблицный документ, получаемый в результате отчета
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
Диалог.Заголовок         = "Укажите каталог для сохранения файлов";
Диалог.МножественныйВыбор    = Ложь;
Диалог.Каталог             = КаталогХранения;
   
Если Диалог.Выбрать() Тогда
   КаталогХранения = Диалог.Каталог + ?(Прав(Диалог.Каталог,1)="\","","\");
КонецЕсли;

Таблица.Записать(КаталогХранения + Метаданные.Метаданные.Имя + ".xls");

Ну можно еще проверку сделать, на то, существует ли файл с таким именем, ну например:

Имя = КаталогХранения+Метаданные.Имя;
Имя = УстановитьНомерФайла(Имя,1);
Таблица.Записать(Имя + ".xls");

Функция УстановитьНомерФайла(ИмяФайла,Нумератор) Экспорт
   Файлы = НайтиФайлы(ИмяФайла+".txt");
   Если Файлы.Количество()>0 Тогда
      Пока Файлы.Количество()<>0 Цикл
         Нумератор = Нумератор + 1;
         Файлы = НайтиФайлы(ИмяФайла+"("+Нумератор + ").xls");
      КонецЦикла;
      Возврат(ИмяФайла+"("+Нумератор + ")");
   КонецЕсли;
   Возврат(ИмяФайла);      
КонецФункции

Оффлайн Marta_Li

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-01
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо большое за ответ, sergeevds . В некоторых отчетах (где в любом случае нужно сохранение во внешний файл) я добавляла подобную обработку. Если действительно нет возможности добраться до передачи типа файла по умолчанию в форму сохранения, то придется кругом вставлять ее в отчеты.

Оффлайн sergeevds

  • ***
  • Сообщений: 202
  • РЕПУТАЦИЯ: 38
  • КПД: 19%
  • Регистрация: 2011-08-18
  • Сайт: 
  • Профессия: Программист 8.1
Для собственно незачто, особенно если сама уже добавляла такое. =)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4490
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15971
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4215
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 650
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1601
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 336
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal